cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error 2885 when installing the agent on Windows

Error 2885 when installing the agent on Windows

Symptoms:

When installing the Windows agent with a full UI on a device without Windows Installer 5.0, you will receive runtime error 2885.

 

Diagnosis:

Starting with the release of 2019 R2 (version 14.0) a hyperlink control was added to the installer dialogs to access our clickthrough EULA. Support for hyperlinks was added in Windows Installer 5.0 (Server 2008 R2/Windows 7 and later). If you install the agent with a full UI on a device without Windows Installer 5.0, you will receive runtime error 2885.

 

Solution:

If you are installing on a version of Windows that does not support Windows Installer 5.0, you will need to run the installer silently.

EXE: setup.exe /s /v"/qn"
MSI: msiexec /i "FlexNet Inventory Agent.msi" /qn

 

Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Apr 13, 2022 09:33 AM
Updated by:
Contributors