Some users may have issues creating a community account See more here.

Compliance Import fails with the error "Cannot open database "<Databasename>" requested by the login. The login failed."

Compliance Import fails with the error "Cannot open database "<Databasename>" requested by the login. The login failed."

Summary

The Compliance Import fails with the error "Cannot open database "" requested by the login. The login failed.", this can been seen in the importer log file.

Symptoms

The Compliance Import fails with the following error message listed in the "Importer.log", when running the import manually this will also fail and produce the same error message.


Error:
" Importing from '<DatasourceName>' [type: <DatasourceType>
<TimeStamp>[FATAL] The import process has failed with the following error (use -verbose to see error details):
Error: Cannot open database "<DatabaseName>" requested by the login. The login failed.
Login failed for user '<AccountName>'.
There is a possible connection type mismatch: check that the database is of the correct connection type
Cannot open database "<DatasourceName>" requested by the login. The login failed.
Login failed for user '<AccountName>''."

Cause

This error is caused by the credentials used by FlexNet Manager Platform not being able to access the datasource listed in the error message.

Resolution

To resolve the connection issue ensure the credentials used are correct for the datasource, this can be verified on the "Connections" tab by right clicking on the "FlexNet Manager Platform" node and selecting "Properties" or if a Beacon is used on the "Inventory Systems" tab from within the BeaconUI.

In addition to this, the following should also be verified:
-The account listed in the error is not locked.
-The account listed in the error has the correct permissions to access the datasource.

Was this article helpful? Yes No
No ratings
Comments

I get this error on 2018 R2, what are the steps to fix the issue on this version?

@JanPie  - The resolution should be the same.  The error indicates that your Service Account does not have SQL Server access to the indicated database name.  Make sure that your Service Account is DBO to the 4 SQL Server databases for FlexNet Manager.

@kclausen - Do you know if there is a way to update databases, so other account will be used?

This is related to reflection of PROD data in nonPROD environment and we use different accounts in each.

After installation was completed in nonProd I ran configuration script using nonProd credentials, but probably some values were not changed (for example for Connection 'FlexNet Manager Suite'  in ComplianceConnection  table,  username is still the production one)

 I was thinking if we can make QAS somehow work, with it's QAS service account.

@JanPie, you would do this directly through SQL Server.  Log in as the SA, add your Service Account as a Logon to the instance, and then grant DBO access to each of the 4 FNMS databases.

@kclausen  I am sorry I wasn't clear before -let me rephrase.

What we did is we deployed new nonProd installation and then restored data from our PRD database to said new deployment.

The problem is that, now nonProduction data is the same as in Production db - and with that, all FNMS Settings in nonProd instance are same as in Production. 

This means that even though we installed nonProd FNMS with FLEXERA-QAS account, and ran configuration scripts using same QAS account  Inventory job is set to be executed by FLEXERA-PRD account.

As per your comment I understand we'd need to grant FLEXERA-PRD logon rights to the instance, but we'd like to to avoid this if possible. I was curious to know if we can modify FNMS settings somehow, so import jobs can be done using nonProd (FLEXERA-QAS) account

Version history
Revision #:
3 of 3
Last update:
‎Sep 17, 2020 01:58 PM
Updated by:
 
Contributors