Activity page is not updated when FlexNet Manager for Engineering Applications and Agents are running on Japanese or Chinese or Korean Windows OS

Activity page is not updated when FlexNet Manager for Engineering Applications and Agents are running on Japanese or Chinese or Korean Windows OS

Summary

Activity page is not updated when FlexNet Manager for Engineering Applications and Agents are running on Japanese or Chinese or Korean Windows OS

Symptoms

Environment:
  • FlexNet Manager for Engineering Applications 15.x or higher
  • Agent 5.x
  • CJK Windows locale
Activity page is not updated when FlexNet Manager for Engineering Applications and Agents are running on Japanese or Chinese or Korean Windows OS.

Cause

FlexNet Manager for Engineering Applications expects the date format as English locale format but Agent sent date locale as localized format of OS locale.

Resolution

FlexNet Manager for Engineering Application running computer:
Please do the following steps after installation and "flexnet make" command.
  1. Stop the FlexNet Manager for Engineering Applications Admin and the FlexNet Manager for Engineering Applications Reporting services
  2. Run Registry Editor (regedit.exe)
  3. Go to HKLM\SYSTEM\CurrentControlSet\services\FlexNet Manager for Engineering Applications Admin\Parameters
  4. Add the following registry entries
    • JVM Option Number 8 = -Duser.language=en
    • JVM Option Number 9 = -Duser.country=US
  5. Update the JVM Option Count value from 0x00000008 to 0x0000000a
  6. Go to HKLM\SYSTEM\CurrentControlSet\services\FlexNet Manager for Engineering Applications Reporting\Parameters
  7. Please do the same steps of 4 and 5
  8. Restart the FlexNet Manager for Engineering Applications Admin and the FlexNet Manager for Engineering Applications Reporting services

Agent running computer:
  1. Stop the FNM-EA Agent service
  2. Open <FNMEA Agent installed directory>\Agent.lax file by text editor
  3. Go to the end of the file, and then add the following line.
    • lax.nl.java.option.additional=-Duser.language=en -Duser.country=US
  4. Restart the FNM-EA Agent service
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Version history
Revision #:
1 of 1
Last update:
‎May 21, 2018 12:34 PM
Updated by: