cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ImIronMan
Level 6 Flexeran
Level 6 Flexeran

Upload File Size in FNMS

Jump to solution

Hi All,

We have master contracts more than 15 MB in size (with lots of pages inside) and not able to upload these files in FNMS > contracts page because the current limit is 10 MB only.

Is there any way that we can increase the limit?

Regards

Rajesh Ponnala

@FNMS

@filesize

@contracts

0 Kudos
1 Solution
mfranz
Level 16 Champion
Level 16 Champion

Hi,

Data type for documents is "image", which per Microsoft should hold up to 2 GB of data.

I found a second setting, you'll need to change in the web.config:

2020-06-25_12h48_44.png

Changing maxRequestLength to 20480 (KiloBytes) fixed it for me. Be sure to set both settings accordingly.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.

View solution in original post

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

4 Replies
erwinlindemann
Level 8 Champion
Level 8 Champion

Hi Rajesh,

Yeah.

Edit the 'maxAllowedContentLength' value in the <location path="Documents/UploadDocument"> section in the following XML file on your FNMS Web Application Server:

 

C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\WebUI\web.config

 

Then do an IISRESET and you should be all set :-).

@erwinlindemann 

Thanks for your quick response. But, it still doesnt work. Same error even after I have changed property in xml to 20 MB

Does it require any reconciliation or any thing else ?

Regards

Rajesh Ponnala

0 Kudos
mfranz
Level 16 Champion
Level 16 Champion

Hi,

Data type for documents is "image", which per Microsoft should hold up to 2 GB of data.

I found a second setting, you'll need to change in the web.config:

2020-06-25_12h48_44.png

Changing maxRequestLength to 20480 (KiloBytes) fixed it for me. Be sure to set both settings accordingly.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.

Thank you very much for jumping in, Markward!

I can confirm that uploading a 20 MB file did work in a FNMS 2019 R2 environment after changing BOTH parameters in the web.config file.