Some users may experience issues accessing the case portal. For more information, please click here.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to access WEB UI - fresh install of FNMS 2020 R1

Jump to solution

Fresh install of 2020R1 - all completed ok
Unable to access the WEB UI
the webui.log has an unhandled error
[ERROR 2020-07-02 10:59:22,094 41807224ms UnhandledErrors ] An unexpected error occurred (3f4fda29-f7ff-4f91-b43a-5f9333b515e2)
System.Web.HttpCompileException (0x80004005): d:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\WebUI\Views\Errors\_Layout.cshtml(49): error CS0012: The type 'System.Object' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.
at System.Web.Compilation.BuildManager.PostProcessFoundBuildResult(BuildResult result, Boolean keyFromVPP, VirtualPath virtualPath)
at System.Web.Compilation.BuildManager.GetBuildResultFromCacheInternal(String cacheKey, Boolean keyFromVPP, VirtualPath virtualPath, Int64 hashCode, Boolean ensureIsUpToDate)
at System.Web.Compilation.BuildManager.GetVPathBuildResultFromCacheInternal(VirtualPath virtualPath, Boolean ensureIsUpToDate)
at System.Web.Compilation.BuildManager.GetVPathBuildResultInternal(VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
at System.Web.Compilation.BuildManager.GetVPathBuildResultWithNoAssert(HttpContext context, VirtualPath virtualPath, Boolean noBuild, Boolean allowCrossApp, Boolean allowBuildInPrecompile, Boolean throwIfNotFound, Boolean ensureIsUpToDate)
at System.Web.Compilation.BuildManager.GetVirtualPathObjectFactory(VirtualPath virtualPath, HttpContext context, Boolean allowCrossApp, Boolean throwIfNotFound)
at System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp)
at System.Web.WebPages.BuildManagerWrapper.CreateInstanceOfType[T](String virtualPath)
at System.Web.WebPages.VirtualPathFactoryManager.CreateInstanceOfType[T](String virtualPath)
at System.Web.WebPages.WebPageBase.CreatePageFromVirtualPath(String virtualPath, HttpContextBase httpContext, Func`2 virtualPathExists, DisplayModeProvider displayModeProvider, IDisplayMode displayMode)
at System.Web.WebPages.WebPageBase.<>c__DisplayClass7.<RenderPageCore>b__6(TextWriter writer)
at System.Web.WebPages.WebPageBase.Write(HelperResult result)
at System.Web.WebPages.WebPageBase.RenderSurrounding(String partialViewName, Action`1 body)
at System.Web.WebPages.WebPageBase.PopContext()
at System.Web.Mvc.ViewResultBase.ExecuteResult(ControllerContext context)
at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass25.<BeginInvokeAction>b__22(IAsyncResult asyncResult)
at System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeAction(IAsyncResult asyncResult)
at System.Web.Mvc.Controller.<>c__DisplayClass1d.<BeginExecuteCore>b__18(IAsyncResult asyncResult)
at System.Web.Mvc.Async.AsyncResultWrapper.<>c__DisplayClass4.<MakeVoidDelegate>b__3(IAsyncResult ar)
at System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult)
at System.Web.Mvc.Async.AsyncResultWrapper.<>c__DisplayClass4.<MakeVoidDelegate>b__3(IAsyncResult ar)
at System.Web.Mvc.Controller.EndExecute(IAsyncResult asyncResult)
at System.Web.Mvc.MvcHandler.<>c__DisplayClass8.<BeginProcessRequest>b__3(IAsyncResult asyncResult)
at System.Web.Mvc.Async.AsyncResultWrapper.<>c__DisplayClass4.<MakeVoidDelegate>b__3(IAsyncResult ar)
at System.Web.Mvc.MvcHandler.EndProcessRequest(IAsyncResult asyncResult)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
[DEBUG 2020-07-02 11:01:31,147 500ms LoggingConfigurator ] Loaded configuration from C:\ProgramData\Flexera Software\Compliance\Logging\WebUI.config
[DEBUG 2020-07-02 11:01:31,163 515ms LoggingConfig ] Logging configured
[INFO 2020-07-02 11:01:31,210 562ms ResolverConfig ] Configuring resolver
[DEBUG 2020-07-02 11:01:31,335 687ms istryConnectionFactory ] Connection string for tenantUID= type=FNMP: 'Server=MSTVSAMPSQL01\UMGBSAM01;Database=FNMP;Trusted_Connection=yes;'
[INFO 2020-07-02 11:01:32,694 2046ms vicePointManagerHelper ] Security protocols Tls, Tls11, Tls12 are in use.

0 Kudos
1 Solution

Problem resolved

Removed the 2020 R1 installation and IIS and started from the beginning.

All now up and running.

Thanks for all input.

View solution in original post

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

10 Replies

Sorry for asking the obvious: When you configured IIS, did you enable the .NET Extensibility and ASP.NET features as documented in the "Installing FNMS on Premises" documentation?

 

0 Kudos

Sorry, should have been clearer - this is an upgrade to a fully functioning 2019 R2 installation

and yes, all configured

0 Kudos

Hi @Smitty987

Microsoft says: To resolve this problem, install the updated version of the Microsoft .NET Framework 4.5.2 Developer Pack. For download information, see Microsoft Knowledge Base article 2901951 .

Hi,

Already installed.

Thanks

0 Kudos

Problem resolved

Removed the 2020 R1 installation and IIS and started from the beginning.

All now up and running.

Thanks for all input.

0 Kudos

Hi, I have exactly the same issue. Are you saying that you resolved the issue by completely removing the previous version of FNMS and also removing IIS, then carrying out a fresh installation of both?

0 Kudos

Hi,

Yes, started from the beginning - obviously removing IIS means you need to go through the pre-requisites to ensure everything is installed.

The only other thing I did was to rename the folders to FNMS so that the path when running the .ps1 file was shorter

i.e. FlexNet Manager Suite Installer 2020 R1\FlexNet Manager Suite\Support  - became FNMS\FNMS\Support

Good luck !

0 Kudos

Hi, just wanted to add that this issue has been identified as a bug by Flexera (bug ID: IOJ-2128316).

It can be fixed by adding a line into the web.config <assemblies> section as per below

<assemblies>

  <add assembly="DevExpress.Data.v15.1, Version=15.1.15.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

  <add assembly="DevExpress.Printing.v15.1.Core, Version=15.1.15.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

  <add assembly="DevExpress.Utils.v15.1, Version=15.1.15.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

  <add assembly="DevExpress.Web.ASPxTreeList.v15.1, Version=15.1.15.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

  <add assembly="DevExpress.Web.Mvc.v15.1, Version=15.1.15.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

  <add assembly="DevExpress.Web.v15.1, Version=15.1.15.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

  <add assembly="DevExpress.RichEdit.v15.1.Core, Version=15.1.15.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a" />

– to add – <add assembly="System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>

</assemblies>

After making the update to the web.config restart IIS to load the new config

Thank you for the valid workaround @michael_hoogen

The product team has identified a defect logged under FNMS-68929.  An KB article is also created for the affected user to apply the workaround.

 

https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/Accessing-FNMS-site-returns-500-internal-server-error-after/ta-p/155013

 

Cheers

Kevin 

(Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".)

Hi,

I've checked our system and the 

"add assembly="System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/"

line is already present in the web.config file.

Not sure if it was previously missing when \i was getting the error.

Thanks

0 Kudos