Previously working Microsoft 365 connector not working after token refresh

Our client refreshed the token for the Microsoft 365 connector which had previously been working.

This error message now appears:

Failed to execute Reader 'Get Usage from Office 365 Exchange' from file C:\ProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Reader\microsoft 365\Usage.xml, at step line 1
Error: Unable to connect to the remote server

It has been verified the account used has both the Cloud Application Admin and Reports reader roles.

This client has registered an app using the Azure portal to connect to Microsoft 365.

This is a bit different error message than seen in similar posts. Please help resolve this issue.

0 Kudos
7 Replies
winvarma
Level 10

Hi ,

Check if there is a proxy enabled/required and Is this a cloud setup? if yes we can just go with the default auto populated inputs in the below fields.

Authorization endpoint:

Token Endpoint:

Application Client ID:

Redirect URL:

Its good to check the connectivity after the Token refresh by hitting the test connection button available.

seems like the Beacon is Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it, where the data received is not being able to upload seems like the issue with the connectivity itself.

if everything above is intact Please go through the other community thread for further reference.

https://community.flexera.com/t5/FlexNet-Manager-Forum/Firewall-openings-needed-to-make-Microsoft-36...

 

Regards,

 

0 Kudos

Hello, We have the same issue, our Beacon is on Prem.
The connection was now working after the refresh but the problem is the same. 
I can't fully understand the Thread you have sent. 

0 Kudos
ImIronMan
Flexera
Flexera

@donald_helliwell, We too facing the exact same issue with the same error message, after upgrading fnms to 2020R2.  Did you manage to resolve it?

The test connection is successful but the import failing

@winvarma @kclausen 

0 Kudos

Hi @donald_helliwell ,

Could you please let know which version of FNMS you are using and is it on-prem/cloud? If you are using an older than FNMS 2019 R1, Please try the work around suggested in the KB article https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/Office-365-import-is-failing-during-... 

Hi @Aperalta , Please try the work around as mentioned in the above KB article if your issue is similar.

hi @ImIronMan ,

what does your log files show related to this integration/import?

*Please share the solution if the issues are fixed for the knowledge of other Forum members.

Regards,

0 Kudos

@winvarma 

Here is the extract from log. Attached the full log file as well. This was working fine before our fnms upgrade exercise over the weekend.

FYI : Self Upgrade of beacon was not successful, we just ran the beacon installer and it went through well, other jobs on the beacon running fine

2021-05-24 11:09:50,616 [INFO ] Failed to execute Reader 'Get Usage from Office 365 Exchange' from file C:\ProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Reader\microsoft 365\Usage.xml, at step line 1
Error: Unable to connect to the remote server
2021-05-24 11:09:50,616 [INFO ] All retries have been attempted for Reader 'Get Usage from Office 365 Exchange'
2021-05-24 11:09:50,616 [INFO ] Completed with error in 6 minutes, 16 seconds.
2021-05-24 11:09:50,616 [ERROR] System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 13.69.251.46:443
at System.Net.Sockets.Socket.InternalEndConnect(IAsyncResult asyncResult)
at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
--- End of inner exception stack trace ---

0 Kudos

Hi @ImIronMan ,

have you tried re-configuring the  Microsoft 365 integration with auto populating the default values while creating the integration?

Can you also confirm your  Reader config file version is readerV3.config/readerV2.config from the path C:\ProgramData\Flexera Software\Compliance\ImportProcedures\Inventory\Reader\Microsoft Office 365\

is there a chance to try the workaround suggested in the https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/Office-365-import-is-failing-during-...  as the issue seems to be similar with yours in the work around but only the Suite version applicability is a dilemma.

Regards,

0 Kudos

Hi @winvarma 

We have not tried re-configuring o365

reader version is 3. - readerV3

And as per KB article that bug should be fixed in 2019 R1. So afraid if changing those settings on fnms 2020R2 could cause any other issues or miss any potential information from o365

0 Kudos