Some users may have issues creating a community account See more here.

flexeranoob
Frequent contributor

Operating System not getting captured correctly / harddisk partition information captured

We are unable to capture the Operating System information correctly.  The Partition information is getting captured.  For e.g. 

Microsoft Windows Server 2016 Standard|C:\Windows|\Device\Harddisk0\Partition2

This is happening with servers as well as desktops.  I saw some knowledgebase article around this from long back, but did not really understand how to rectify it.  Can someone help please.

0 Kudos
11 Replies
dennis_reinhardt
Frequent contributor

Hi @flexeranoob 

please try this workaround first - https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/Operating-System-Name-not-detected-c...

If this does not help, please open a new support case and tell the support the missing operating systems, so they can add the following false detected operating systems into the next ARL update.

 

Best,

Dennis

I tried understanding this workaround, but I am not sure I could figure out what this meant. Do I need to update the agent?  That is not an option.   Do I make the changes on Application Server? Database server?  Its not very clear.

0 Kudos

You don't have to do any changes to the FNMS agent. The workaround is performed on the application server.

I used Option B and copied the current OSMap.txt where InstallDir points to and this solved our naming problem.

 

Best,

Denni

Thanks @dennis_reinhardt however, i could not find a Reporter folder inside C:\Program Files (x86)\Flexera Software\Flexnet Manager Platform or OSNameMap.txt anywhere on the server

0 Kudos

Hi @flexeranoob 

please open the mentioned reg-key and checke your local paths for ComplianceInstallDir and InstallDir.

The original OSMap.txt can be found in the ComplianceInstallDir Reporter folder. Please copy this folder to the InstallDir. If it's possible please restart all Flexera Services to be sure the new file is recognized by the system and run a complete reconciliation including inventory.

dennis_reinhardt_0-1586974795992.png

Best,

Dennis

folder.JPGStill no luck.  My ComplianceInstallDir Folder is C:\Program Files (x86)\Flexera Software\FlexNet Manager Platform\ but no Reporter folder here. No OSMap.txt either.  let me open a ticket,

0 Kudos

Do you have multiple servers? The OSMap.txt file will be on the inventory server (not the web or batch server, if you have separate servers).

If you do have a single server, search the entire filesystem for the OSMap.txt file; it should be there somewhere! You wouldn't be getting any inventory file details imported if the components associated with that file are not installed somewhere.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
flexeranoob
Frequent contributor

Yes indeed we have multiple servers. I was looking for it on application server earlier.  Found this in inventory server. Have made the changes. I suppose I will have to wait for a full recon to see the results. Thank you!

@flexeranoob 

We had this issue in the past too and after applying the change only those agents that delivered a new inventory afterwards showed a change.

Outdated agents were still showing the OS with partion information

Thanks.  We do have the agents running through the week, and so hopefully within a week, it will be reflected properly.

0 Kudos

HI All,

 

Just wanted to provide a quick update. The fix is working.  All the systems which have an inventory date post the implmentation of fix are reporting correctly. 

 

Thank you for your help!