Showing results for 
Show  only  | Search instead for 
Did you mean: 

On premises 1 Beacon has the upgraded version but the other doesn't still shows awaiting update

Beacon 1 has the newest version 16.2 and is running correctly.

Beacon 2 has the older version 16.1 and is not running correctly.

No real errors in the logs. But under discovery and inventory it does not display the newest version as an option. It only show 16.1. 

I have tried relauching the beacon. I have changed a setting and then changed it back but it still says awaiting update. I verified that it is connecting in IIS. I am not sure at this point how to get the lastest version to update under discovery and inventory.



(7) Replies

can you try manual upgrade & see if any error comes.

How would you manually install it? Download the latest version which has a .PS1 file? Or since others have already been updated get the install file and run it on the beacon? 


You should be able to download the beacon package from the UI:



I eventually had to uninstall and reinstall the beacon which worked.

By Level 6 Flexeran
Level 6 Flexeran

Hello @bottsra , glad reinstalling the newer version of the Beacon has worked. For future reference though, if the auto-upgrade is not working. You can always check the BeaconEngine logs for traces of 'as to why it did not upgrade'. You can also check 'packageretriever.log' to validate if the beacon is even downloading the upgrade package without issues.

I hope that helps.

Now my other beacon is showing the same thing for 2 days. So I checked and there was nothing in the packageretriever.log but the beaconengine.log shows that it didn't update because it is already on version 2470 but the web interface shows 2468. 


can you restart beacon upload task from task scheduler in your beacon.