Highlighted
Occasional contributor

O365 integration stopped working

Team, We have O365 integration with FNMP 2018 R2 which was running successfully till Feb 26th 2020. But from Feb 27th 2020, we are receiving below error message: "Inventory gathering failed. Error: Showing a modal dialog box or form when the application is not running in UserInteractive mode is not a valid operation. Specify the ServiceNotification or DefaultDesktopOnly style to display a notification from a service application." I have tried to run it manually but had no luck. Could you please help me to resolve this issue? Regards, Saurabh
4 Replies
Highlighted
Intrepid explorer

Re: O365 integration stopped working

Microsoft has changed the minimum requirements for authenticating to O365. Two factor authentication is now required, and basic authentication was just retired. 

This is a place to start looking. 

0 Kudos
Highlighted
Occasional contributor

Re: O365 integration stopped working

Hi Jeff,

Thanks for the response. Could you please let me know how to resolve this issue then?
0 Kudos
Highlighted
Frequent contributor

Re: O365 integration stopped working

hi @sharma_sa ,

Not sure if this is the same issue in your case for on prem 2018 R2, it might be worthy if you go through the KB on the recent issue related to O365 issues for 2019R1 and later.

https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/Office-365-Adapter-fails-with-an-err... 

 

Regards,

Winvarma.

0 Kudos
Highlighted
Flexera
Flexera

Re: O365 integration stopped working

Hi Saurabh,

From your post, it appears that you were using the old O365 adapter. This old adapter does not support o365 credentials that have multi-factor authentication enabled, i.e. the account you specify in this old adapter needs to directly authenticate against office.com. It is possible that due to some changes, the Multi Factor Authentication (MFA) has been turned on for this account and hence you are seeing this error. If this is the case, you can try the following options -
1. Check with your IT team and see if they can disable the MFA for this account used in the adapter
2. If the above option does not work for you, then try upgrading to the new o365 adapter released in Fnms 2019 R1. It is compatible with Fnms 2018 R2 beacon and supports o365 accounts that have MFA turned on.

I hope this helps you.

Thanks!