Shashikant
Level 3

Inventory Issues

Hi ,

i see a lot of virtual machine records in the inventory issues node with the red flag saying "The virtual machine does not have a host" can you please let me know what could be the issue and steps to resolve this issue?? i have attached the screenshot for reference

 

Inventory.PNG

 

Thanks,

Shashi

3 Replies
durgeshsing
Level 7

Hi,

You need to ensure Agent is install on Host server in Microsoft hyper V case. Incase devices are coming from vmware then ensure respective Vcenter must be scan.

dbeckner
Level 8

Hi @Shashikant ,

This alert occurs when the virtual machine is not being mapped to the underlying physical host. Typically this occurs when you are not targeting the virtualization infrastructure with a Discovery & Inventory rule. If you have access to the vSphere console for the vCenters you have previously targeted you can confirm the VMware VMs that do not have a host mapped to them do not exist on those hypervisors by searching by VM name. When they dont appear in any of those vCenters then you know that there must be a vCenter somewhere you are not currently targeting. You can repeat this process for the other virtualizaton systems.

kclausen
Flexera
Flexera

@Shashikant - Do these represent the inventory of Amazon and Azure server instances?  If yes, you need to update the "Hosted In" field on the Inventory Device to represent that, rather than having the default value of "On-Premises".  I am quite sure that for Inventory Devices identified as being in the Cloud, that the Alert for not having a host is not displayed.  The "Hosted In" field can be updated using a Business Adapter.