Some users may have issues creating a community account. For more information, please click here.

Kasi23
Occasional contributor

IBM Cognos Service Restart failed

Hi Team,

IBM Cognos Service Restart Failed and it is causing Flexera Analytics Tab in my application.

Error: "Error 1053: The Service did not Respond to the Start or Control Request in a Timely Fashion"

Solutions Tried:

We have tried ServicesPipeTimeout entry in registry editor

Restarted all the SQL Services and Tried Restarting IBM Cognos

Restarted the Computer Several Times

Tried IBM Cognos Service restart from Administrator account

At last reinstalled the IBM Cognos  - Service was not present after uninstallation

 

Even though Facing the same Issue.

Application Wizard snap of IBM Cognos is attached.

Please Find me an solution for this.

 

Thanks and Regards,

Kasinath K

Labels (1)
0 Kudos
9 Replies
kclausen
Flexera
Flexera

@Kasi23 - To be honest, Cognos is a resource hog.  You likely need to consider adding additional RAM and potentially more VCPUs to the machine (assuming it is a virtual server).

Also, I would recommend that Cognos should be installed on its own dedicated server and not be installed on other FNMS Server Components (app server or batch server).

0 Kudos
Kasi23
Occasional contributor

Hi Kclausen,

Thanks for your reply.

The IBM Cognos have deployed in an external server where App server, Batch Server or Inventory Server is not installed in it. And It's RAM is 32 GB and CPU details are 2 x 3.0 GHz Dual. Please Can you provide me an solution.

Regards,

Kasinath K

0 Kudos
cdubs76
Occasional contributor

The logs in the Cognos directory will probably shed more light.   You can also watch the process if you fire up the Cognos Configuration window, and start the service from there.   You'll be able to watch the progress, and see verbose output.  

0 Kudos
Kasi23
Occasional contributor

Hi cdubs76,

I have checked the logs. Seems everything working fine but some errors are being held in those logs. And those logs are: 

Log File - cbs_run_WebSphereLiberty:

Tue Aug 17 10:32:42 2021 INFO t[11a0] CBSBootstrapService attempt to load config from "C:\Program Files\ibm\cognos\analytics\bin64/bootstrap_wlp_winx64.xml"
Tue Aug 17 10:32:47 2021 INFO t[11a0] CBSBootstrapService IBM Cognos Bootstrap Service running as process 1996.
Tue Aug 17 10:34:14 2021 ERROR t[310] CBSSocketCommand no response, CAM_Poll timed out.
Tue Aug 17 10:34:48 2021 ERROR t[11a0] CBSBootstrapService askPCPifReady() - some child processes got fatal errors, stop all processes.
Tue Aug 17 10:34:48 2021 INFO t[11a0] PingChildProcess Child process supervisor has been told to stop
Tue Aug 17 10:34:48 2021 INFO t[310] PingChildProcess stopping child process(es).
Tue Aug 17 10:35:38 2021 WARN t[310] PingChildProcess stopAction->execute() return status = 1468
Tue Aug 17 10:36:40 2021 INFO t[310] PingChildProcess 1 processes are still alive, but we're not going to wait any longer for them to die.
Tue Aug 17 10:36:40 2021 INFO t[11a0] CBSBootstrapService CBSBootstrapService::Run() - returned from m_semaMainThreadWait->wait()
Tue Aug 17 10:36:40 2021 INFO t[11a0] CBSBootstrapService calling m_pStatusUpdaterThread->interruptWait( SERVICE_STOP_PENDING )
Tue Aug 17 10:36:40 2021 INFO t[11a0] CBSServiceStatusUpdater interrupt, final status is 3
Tue Aug 17 10:36:40 2021 INFO t[11a0] CBSBootstrapService Sleep a bit to let the service status updater shutdown.
Tue Aug 17 10:36:40 2021 INFO t[234] CBSServiceStatusUpdater ending, final status is 3
Tue Aug 17 10:36:41 2021 INFO t[11a0] CBSBootstrapService Done.

Log File - Cognosserver

2021-08-17T10:33:56.849+0100 INFO com.ibm.bi.search.SearchService [Default Executor-thread-33] NA Search: Search Service Started.
2021-08-17T10:35:06.224+0100 ERROR com.cognos.pogo.contentmanager.coordinator.ActiveCMControl [Timer-47] NA DPR-CMI-4007 Unable to perform an active Content Manager election on the local IP node. For more information, see the dispatcher and Content Manager detailed logs. Ensure that the local Content Manager service is started.
com.cognos.pogo.bibus.CommandExecutionIOException: Failed to send HTTP request or read HTTP response
at com.cognos.pogo.bibus.BIBusCommand.handleDefaultException(BIBusCommand.java:376) ~[p2pd.jar:?]
at com.cognos.pogo.bibus.BIBusCommand.execute(BIBusCommand.java:209) ~[p2pd.jar:?]
at com.cognos.pogo.contentmanager.StandbyContentManagerElectionCommand.executeIfLocal(StandbyContentManagerElectionCommand.java:53) ~[p2pd.jar:?]
at com.cognos.pogo.contentmanager.coordinator.ActiveCMControl.sendElectCommand(ActiveCMControl.java:213) [p2pd.jar:?]
at com.cognos.pogo.contentmanager.coordinator.ActiveCMControl.access$300(ActiveCMControl.java:30) [p2pd.jar:?]
at com.cognos.pogo.contentmanager.coordinator.ActiveCMControl$GetActiveCMTask.safeRun(ActiveCMControl.java:204) [p2pd.jar:?]
at com.cognos.pogo.util.threads.SafeTimerTask.run(SafeTimerTask.java:40) [p2pd.jar:?]
at java.util.TimerThread.mainLoop(Timer.java:566) [?:1.8.0]
at java.util.TimerThread.run(Timer.java:516) [?:1.8.0]
Caused by: java.io.IOException: Failed to send HTTP request or read HTTP response
at com.cognos.pogo.http.ServerConnection.executeMethod(ServerConnection.java:800) ~[p2pd.jar:?]
at com.cognos.pogo.http.ServerConnection.sendRequest(ServerConnection.java:254) ~[p2pd.jar:?]
at com.cognos.pogo.bibus.BIBusCommand.sendRequest(BIBusCommand.java:234) ~[p2pd.jar:?]
at com.cognos.pogo.bibus.BIBusCommand.executeCommand(BIBusCommand.java:218) ~[p2pd.jar:?]
at com.cognos.pogo.bibus.BIBusCommand.execute(BIBusCommand.java:203) ~[p2pd.jar:?]
... 7 more
Caused by: java.net.ConnectException: Connection refused: connect
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:380) ~[?:1.8.0]
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:236) ~[?:1.8.0]
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:218) ~[?:1.8.0]
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:183) ~[?:1.8.0]
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:403) ~[?:1.8.0]
at java.net.Socket.connect(Socket.java:666) ~[?:1.8.0]
at java.net.Socket.connect(Socket.java:606) ~[?:1.8.0]
at java.net.Socket.<init>(Socket.java:469) ~[?:1.8.0]
at java.net.Socket.<init>(Socket.java:314) ~[?:1.8.0]
at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:80) ~[commons-httpclient-3.1.jar:?]
at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:122) ~[commons-httpclient-3.1.jar:?]
at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707) ~[commons-httpclient-3.1.jar:?]
at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387) ~[commons-httpclient-3.1.jar:?]
at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171) ~[commons-httpclient-3.1.jar:?]
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397) ~[commons-httpclient-3.1.jar:?]
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323) ~[commons-httpclient-3.1.jar:?]
at com.cognos.pogo.http.ServerConnection.executeMethodSynchronously(ServerConnection.java:829) ~[p2pd.jar:?]
at com.cognos.pogo.http.ServerConnection.executeMethod(ServerConnection.java:781) ~[p2pd.jar:?]
at com.cognos.pogo.http.ServerConnection.sendRequest(ServerConnection.java:254) ~[p2pd.jar:?]
at com.cognos.pogo.bibus.BIBusCommand.sendRequest(BIBusCommand.java:234) ~[p2pd.jar:?]
at com.cognos.pogo.bibus.BIBusCommand.executeCommand(BIBusCommand.java:218) ~[p2pd.jar:?]
at com.cognos.pogo.bibus.BIBusCommand.execute(BIBusCommand.java:203) ~[p2pd.jar:?]
... 7 more
2021-08-17T10:35:19.489+0100 INFO com.ibm.bi.search.SearchService [Default Executor-thread-49] NA Search: Search Service Stopped.

0 Kudos

@Kasi23 - Suggest that you:

1) Create a Support Ticket, if you have not yet done so

2) Make sure that you are looking at all the potential Cognos Log files found in C:\Program Files\ibm\cognos\analytics\logs

3) Start to capture any Error Codes/Numbers in the Log Files and Google them for potential troubleshooting hints/resolutions

0 Kudos
Kasi23
Occasional contributor

Hi Kclausen,

Support Ticket in the sense, IBM Support Ticket or Flexera Tool Case?

Thanks and Regards,

Kasinath K

0 Kudos

A ticket to Flexera Support, please.

0 Kudos
cdubs76
Occasional contributor

If it's a simple oversight---Flexera ticket should suffice.  We had issues with SSL configuration on Cognos for over a year with no resolution, and very little help--but everything worked without the SSL piece.  We eventually figured it out on our own (along with new releases of Cognos eventually solving the issue).  It might do you well also to search IBM's support site b/c there is a lot of knowledge base articles that helped us previously on Cognos.  

The suggestion to test connections and start the service from the Config tool will help you with where in the process something is failing.   I would also move the logs files off to a folder somewhere else to back them up, and then attempt to start the service to generate new logs and submit those with your Flexera ticket.

see pictures attached to see what i'm talking about.

the log files are very chatty---but they have a lot of good info in them, but there's a lot of them.  I would send all of them in that folder in your ticket.

 

0 Kudos
stefange
Active participant

Hi Kasi23,

Do you know if you are able to start the service from the CogConfig.bat executable? (Cognos Configuration), are all the test succesfull?

Please test your settings first before starting the service. If the Cognos service does not start, most likely there is a misconfiguration in your settings.

Stefan

0 Kudos