pevpov
Level 3

How to Discover VMWare Infrastructure and Inventory

Jump to solution

Hi,

How to discover VMWare Infrastructure and Inventory using FlexNet Manager Suite (Cloud) ?

I've configured the action (Please refer to action.JPG). But, it's still not working.

Is there any prerequisite to discover VMWare ? 

Could you give me spesific steps to discover VMWare ?

 

Thanks

Labels (1)
0 Kudos
1 Solution

Hi @pevpov,

Can you please check if your VMware servers are responding to a PING (ICMP) requests from the Beacon(s) that are configured for network discovery on the subnet the VMware servers are located in?

By default, getting a response on a PING request is a prerequisite for the discovery of devices and for VMware scanning.

You can change the DefaultPingSweepOptions on your Beacons manually to get rid of this limiation. This is also described in the following KB article: How to allow beacon network scans in a network with ICMP disabled.

 

View solution in original post

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

5 Replies
mfranz
Level 16 Champion
Level 16 Champion

Hi,

Please also make sure to assign all relevant subnets to your Beacons. The Beacons will only take action within the subnets assigned to them.

Best regards,

Markward

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos

I've assign all relevant subnets to my Beacon. But, they aren't triggered properly. (Please refer to result.JPG)

0 Kudos

Hi @pevpov,

in addition to what Markward suggested, you should also Make sure that you have read only access to the Vcenter's in your infrastructure and configure the credentials in the Password manager and also mention the Vcenter host name and ip's are populated in the Targets and run the rule. This should give the cluster,host and VM relationship details and the Inventory.

hope this helps.

Regards,

0 Kudos

Hi @winvarma ,

 

Thanks for your response.

These are the steps that I've done. Please let me know if there is something I have not done yet.

 

On my local and my vm :

- Turn off firewall and windows defender

- Disable anti-virus

- Enable ICMP v4

- Enable port 135, 137, 139, 161, 445, 80, 161, 443, 1433, 1521, 2483, 7001, 7002, 22, 389, 2483-2485 (Inbound and Outbound)

- Enable service account to log in as a batch job

 

On FlexNet Manager Suite (Cloud) :

- Create rule

- Create Action

    >> Action Type : Discovery and inventory

    >> Network scan with ports 22, 135, 139, 161, 445, 80, 443  (Please refer to rule1.JPG)

    >> I choose "Gather hardware and software inventory from all target devices"

    >> I choose "Discover VMware infrastructure" and also checked on "Gather VMware infrastructure inventory, with advanced recognition of VMware applications"  (Please refer to rule2.JPG)

- Choose Target. Before that, 

    >> I've configured ip local and ip vm in subnet first And I assigned ip local and ip vm in subnet to my beacon.

- Save my rule

 

On my FlexNet Beacon UI :

- I've configured my local and my vm credential in password management.

- Test connection in parent connection is succeeded

- I click update rules

- Then, i run my rule. But the result is 0 (Please refer to reslt.JPG)

 

Thanks,

@pevpov 

 

0 Kudos

Hi @pevpov,

Can you please check if your VMware servers are responding to a PING (ICMP) requests from the Beacon(s) that are configured for network discovery on the subnet the VMware servers are located in?

By default, getting a response on a PING request is a prerequisite for the discovery of devices and for VMware scanning.

You can change the DefaultPingSweepOptions on your Beacons manually to get rid of this limiation. This is also described in the following KB article: How to allow beacon network scans in a network with ICMP disabled.