iammanzi
Frequent contributor

How does a FlexNet Agent work if machines are cloned and then renamed

Good day

As we deploy new VM's in a clients environment with the FlexNet Agents as part of the build, IP's and hostnames will be changed.

So, we take 1 image, clone it and then rename the host.

How does the FlexNet Agent pick up the new VM details? Would it be after a re-boot?

regards
Manish

13 Replies
WheresThePizza
Flexera
Flexera

As long as the changes were made before the agent runs its scan, I would expect it to pick up those changes, unless a specific change requires a reboot to take effect. The one thing to keep in mind when doing this, is that FNMS will try to match inventory records based on certain criteria. In this regard, if you are not seeing inventory records for cloned devices, they could be merging with another record. All of the logic for matching can be found under the following path on the application server:
%ProgramData%\Flexera Software\Compliance\ImportProcedures\Inventory\Matcher


dcollins
Flexera Alumni

once the hostname has been successfully changed it should pick it up at the next scheduled time for the agent to generate a ndi (generally every 24 hours, it's defined in the WebUI)

it's worth noting however if your cloning a VM and want it to come in as a separate record you need to change more than just the hostname, from the top of my head it also merges on the domain and serial number.
(the matching logic should match on hostname and domain name if the serial number is not available. )
For more information on the importer matching logic, you can see the 'Common: Resolving Inventory Records' section in the Gathering FlexNet Inventory PDF.
https://www.linkedin.com/in/dave-collins-7aa71a3b
0 Kudos
FrankvH
Intrepid explorer

At this moment we have a support case open that the rename is not reflecting back in FNMS. This is not specific related to cloning but just in general rename of VM or physical server.

We see the agent report back with new name (ndi contains new name) it is updating the device but not the hostname.

I found out be removing the discovered device and inventory the next time the agent reports it has the correct name.

Wait for solution from Flexera.

0 Kudos

Hi Manish and Frank,

Do you the version of FNMS in use? FNMS 2018 R1 and earlier used to have a defect (Only impact windows device/s connected to domain) if device is renamed, host name was not getting updated in FNMS but other properties (hardware and software data) were getting updated, even latest inventory file does report new device name. 

FNMS 2018 R2 and later have fix for this issue. 

If my understanding is correct, you can apply the attached SQL fix to inventory database (not compliance database) that will fix the issue.

Note: This fix should not be applied to FNMS 2018 R2 and later versions and applies to On-Prem version only.

Hope this will help.

Aamer

Hello Aamer,

 

Thanks we running R2018R1 so this clears a lot 🙂

I will the test the sql if this solves the issue.

Regards

Frank

0 Kudos
iammanzi
Frequent contributor

Hi Aamer

 

We are using 2018 R2

0 Kudos

Hi Manish,
FNMS 2018 R2 already have fix for the issue I described earlier, May be you are facing different issue, Can you check again database version of IM database if it is FNMS 2018 R2 please reach out to Flexera support, support can help with further investigations.
If you do have more issue specific information please do share here.
Thanks
Aamer
0 Kudos

Hi all,

did anyone find a solution for this problem? We also facing the issue that our customer is cloning some vm's where the agent is already installed and working. On the cloned server the agent seems to work and upload an inventory, but there is nothing incoming to in IM DB.

 

Thanks

Daniel

0 Kudos

Hi all,

I'm not sure about this, may be I'm wrong, but as I remember in FNMS 2019 R2 flexera use UUID embedded in the .ndi file, as I understand this is a uniq generated value per servers, may be when you clone the VM you clone with this value, and then when you upload the .ndi file, he will check this value and will not import the data. 

Also other question, when you clone the VM, the serial number is changed?

Also for testing reason, did you try on a cloned VM to uninstall the agent to reinstall it, also deleting the corresponding registry key?

 

0 Kudos

In case you are working with FNMS 2019 R2 (or higher), you will have to make sure that the AgentID value is updated after cloning your VM. In newer FNMS releases, the AgentID value takes precedence over the older "Matching" algorithms. On Windows computers, the AgentID value is being cached in the Registry and will have to be updated after cloning a VM.

In case the AgentID does not change, the Inventory data of the cloned VM would overwrite the Inventory data of the parent VM that has been cloned.

In March 2020, there has been a discussion in this forum on how the AgentID value is being generated.

My recommendation would be to compare the AgentID value in the NDI files generated in both VMs - cloning source and cloned - and make sure that they are different.

@adrian_ritz1 thanks for your reply, the uuid's are different. Next step is to reinstall the agent, but after a reboot, the cloned vm will have his initial state again.

@erwinlindemann yes, the agent id's are the same and that seems to be the problem. But all the values are different. We've raised a support case. 

 

Thank you and i'll keep you up to date on this case 🙂

This sounds like absolute mayhem to me.  We are embedding Flexera agents in our images for OS, and what this implies is that those machines will not be recorded unless some manual changes are made post the cloning of image.  This is NOT how it should perform.  This destroys the whole objective of embedding in the image if manual interventions are needed post the cloning.   Is there no way to use  a Serial number matching etc. 

This is just not right. 

0 Kudos

Hi @flexeranoob ,

Instead of including the Flexera agent in the Image itself i would suggest that the agent should be installed separately once the OS is installed as we install the sccm, Antivirus using a script to deploy the agent or via sccm/bigfix etc so that it will avoid any further issues like uid duplication's etc.

Just my thoughts on your issue.

 

Regards,

0 Kudos