Some users may experience issues accessing the case portal. For more information, please click here.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Flexera Analytics - Error: The custom login perspective not found

Hi Flexera Community,

I have Installed and configured Flexera Analytics and try to access the url

http://localhost/ibmcognos/bi

getting error "The custom login perspective not found Will set factoryMode=true to use default IBM login view instead".

Kindly let me know if anybody facing this issues or have solution for this issue.

Regards,

Shahul Hamid Bathusha

8 Replies

@sbathusha 

I can see that you've raised this with Flexera Support to get assistance troubleshooting the issue.

Please update the community with its resolution if you think that other forum members could benefit from it.

Thanks,

I'm also keen to here how this is resolved.

 

I've been having trouble installing 2022R1 Analytics in my instance. Install Cognos manally, then applied the rest of the configuration without error.

But I now get the same error.

 

j

 

0 Kudos

I've solved this one for my case. Silly mistake on my part fixing the installer location before running InstallCognos.ps1.

 

Still interested in this issue though.

j

 

0 Kudos

@JohnSorensenDK 

There is no response from Flexera Support. Its been more that a month and no response.

Thats reason I have put here in the community.

0 Kudos

@sbathusha 

I just checked and can see that the support case is in progress again now. I think this issue will have to be resolved through a support engineer providing guidance in troubleshooting it as it may be something in the environment that causes it.

Thanks,

0 Kudos

I am getting the exactly this is the error which i have attached here FYR.

0 Kudos

In the cognosserver.log file, i am getting error during the login process in the IBM cognos web console.

 

2022-12-16T09:38:31.942-0800 ERROR com.ibm.ba.glass.utils.PluginUtils [Default Executor-thread-82] CydvCMCs8wwj4sqh48w4Gdvqyd9qhMv2q8l9yyGv CydvCMCs8wwj4sqh48w4Gdvqyd9qhMv2q8l9yyGv NA 192.168.10.103 53312 _unknown_ NA /v1/perspectives/login bi-service 1636 Request for current theme spec returned invalid JSON. skipping...
com.ibm.ba.glass.utils.ESException: Failed to parse json file
at com.ibm.ba.glass.resource.ThemeSpecResource.getResourceAsJson(ThemeSpecResource.java:54) ~[ba_glass_server_core-11.0.13-21051107.jar:11.0.13-21051107]
at com.ibm.ba.glass.utils.PluginUtils.getCurrentTheme(PluginUtils.java:41) [ba_glass_server_core-11.0.13-21051107.jar:11.0.13-21051107]
at com.ibm.ba.glass.endpoints.PerspectivesResource.getCurrentTheme(PerspectivesResource.java:137) [ba_glass_server_core-11.0.13-21051107.jar:11.0.13-21051107]
at com.ibm.ba.glass.endpoints.PerspectivesResource.getModelConfig(PerspectivesResource.java:129) [ba_glass_server_core-11.0.13-21051107.jar:11.0.13-21051107]
at com.ibm.ba.glass.endpoints.PerspectivesResource$Perspective.getPerspectiveDefinition(PerspectivesResource.java:249) [ba_glass_server_core-11.0.13-21051107.jar:11.0.13-21051107]

0 Kudos

Hi All,

When I am trying to register through "Flexera Report Designer Package Utility" and getting error which I have attached here.

0 Kudos