andresdarquea
Flexera beginner

Flexera 2019 R2 Inventory Records not getting deleted

Dear  Comunity,

Durin this year, we have been experiencing some strange situations. We have currently upgraded into FNMS 2019 R2 on Premise.

Before those upgrades we were able to delete devices from UI with success, and if the device wouldnt report back again, then it wouldnt reappear into the UI, which tu us, it seemed to be working as intented. Please do note that back in previous versions we also had the AD connecter stablished as per default, meanwhile there was NO AD management (which means no disabled devices and records back from 2015 till present).

However lately we have been trying to deleted over 5 times the inventories that we do not want to have in the UI, and after every single reconciliation the inventory would report back with the last inventory date that the device reported, but with the created date as in the day that was re-created after the reconcile.

Please do note that we do not have any third party connector, we run only the Agent Inventory and the default AD connector. 

 

Any thoughts on where the problem is?

 

0 Kudos
7 Replies
kclausen
Flexera
Flexera

Re: Flexera 2019 R2 Inventory Records not getting deleted

@andresdarquea - Here is another thread on the Community on this same topic.  If your only source of inventory is the FlexNet Manager Agent, then to permanently delete this from FNMS (assuming the agent is not reporting inventory), then you must delete the device from both of these views.  If you only delete from the Active Inventory view, it will come back after the next import:

1) Active Inventory

2) All Discovered Devices.

Also since you have FNMS On-Premises, there are some references to Stored Procedures in the FNMSInventory database that you can run to delete inventory that way.

https://community.flexera.com/t5/FlexNet-Manager-Forum/Deleting-old-inventory-records/td-p/99395

andresdarquea
Flexera beginner

Re: Flexera 2019 R2 Inventory Records not getting deleted

Thanks for the quick reply, I would like to inform you that I have performed the advised steps, however it turns out that after deleting all of the inventory and all of the discovered devices then executed the reconcile, once the reconcile was done, all of the devices were there again. everything like if almost nothing got deleted.

In addition to the thread suggested, I am guessing that the AD section where it is mentioned that devices get deleted from UI IF within the AD they are deleted or marked as disabled, that doesnt mean that the inventories cant be deleted manually right? To be more detailed on my question:

There is no AD manager, so nobody sets up disabled or clears the AD. But what i would do is the device no longer reports, so i just go ahead an removed it from the UI. Back in previous versions I was able to perform such action without the inventory being re-created..

 

Any other advice or step I could take on this problem am having?

0 Kudos
kclausen
Flexera
Flexera

Re: Flexera 2019 R2 Inventory Records not getting deleted

Option B is to simply go to Active Inventory and change the status of the Inventory Device from Active to Ignored.

When an inventory device is set to a status of Ignored:
1) Any software installed on that device will be ignored by Software License Reconciliation/Consumption
2) The inventory device will not be counted by your FlexNet Manager License

 

You may also want to look into some of the SQL Scripting mentioned in the other Community Thread.

0 Kudos
jlu_tmg100_c
Active participant

Re: Flexera 2019 R2 Inventory Records not getting deleted

Hi,
I just had a cae open about this.

If you've got some SQL skills, open up the FNMSCompliance database, and check the dbo.ImportedComputer table. Thats where all incoming data from agents, SCCM, etc get put.

Even if you have deleted objects from the gui, the data for the agent may still be kicking around in that table.

Select * from dbo.ImportedComputer where ComputName = 'devicetodelete'
0 Kudos