bmaudlin
Level 8

FlexNet Manager Platform cannot access the directories

Hi Guys,

I am having trouble with a number of AIX/Linux servers, that when installing the applicable agent, present me with the below error.

The user is installing as root, has anyone seen this error before, and how do I resolve?

The log file just states the same error.

Tue Oct 27 15:05:54 GMT 2020 (U, 0)] {26542246} FlexNet Manager Platform cannot access the directories describing your FlexNet Manager Platform applications.
Please review your application directory settings.
See log file for more details.
6 Replies
kclausen
Flexera
Flexera

Are you using the correct agent install package for the platform you are installing on?

Are you launching the installation package as root, or sudo to root?

0 Kudos

Correct install package is being used, and user is logged in as root.

Ben

0 Kudos

@bmaudlin 

Please try the following steps and if you still don't make any progress then please create a support case to get assistance troubleshooting further:

Uninstall the agent
rm -rf /var/opt/managesoft
Install the agent

Thanks,

0 Kudos

Hi Guys,

I am seeing a further error, along similar lines, any thoughts?

[root@sniptmp]# /bin/bash  /var/tmp/linuxmgssetup_v2.sh

Running /var/tmp/linuxmgssetup_v2.sh from /var/tmp........

        Removing existing Managesoft Agent..............

error: rpmdb: BDB0113 Thread/process 32447/139766448248896 failed: BDB1507 Threa                                                                             d died in Berkeley DB library

error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal erro                                                                             r, run database recovery

error: cannot open Packages index using db5 -  (-30973)

error: cannot open Packages database in /var/lib/rpm

error: rpmdb: BDB0113 Thread/process 32447/139766448248896 failed: BDB1507 Threa                                                                             d died in Berkeley DB library

error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal erro                                                                             r, run database recovery

error: cannot open Packages database in /var/lib/rpm

error: package managesoft is not installed

        Removing existing Managesoft folder.............

        Installing FlexNet Inventory Agent

error: rpmdb: BDB0113 Thread/process 32447/139766448248896 failed: BDB1507 Threa                                                                             d died in Berkeley DB library

error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal erro                                                                             r, run database recovery

error: cannot open Packages index using db5 -  (-30973)

error: cannot open Packages database in /var/lib/rpm

error: rpmdb: BDB0113 Thread/process 32447/139766448248896 failed: BDB1507 Threa                                                                             d died in Berkeley DB library

error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal erro                                                                             r, run database recovery

error: cannot open Packages database in /var/lib/rpm

Applying custom configuration into config.ini

*** Error: Error (s107m607)

***   FlexNet Manager Platform cannot access the directories describing your Fle                                                                             xNet Manager Platform applications.

Please review your application directory settings.

See log file for more details.

tail: cannot open ‘/var/opt/managesoft/log/installation.log’ for reading: No suc                                                                             h file or directory

 

ChrisG
Community Manager Community Manager
Community Manager

Those latest messages suggest that the RedHat Package Manager database on this computer is corrupted.

Some commands that may help to repair this database are:

mkdir -p /var/lib/rpm/backup
cp -a /var/lib/rpm/__db* /var/lib/rpm/backup/
rm -f /var/lib/rpm/__db*
rpm --rebuilddb

 

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

I wanted to touch base to see if there was any further progress with this issue?  I too am seeing this problem sporadically across the enterprise with the 2020 R1 agent.

0 Kudos