Some users may have issues creating a community account. For more information, please click here.

dcopher
Active participant

FNMS + Tanium Import Error

When importing data into FNMS using the Tanium adapter the following error is thrown: "Error: Exception calling 'GetComputers' with '6' argument(s): 'Index was outside the bounds of the array.'"
 
Has anyone else encountered this issue and if so what is the work around?
 
Attached is the importer log.
0 Kudos
10 Replies
AamerSharif
Flexera
Flexera

I noticed command line has parameter ReadersAndWriters, is it possible direct (On the batch server) Tanium inventory connections created? If yes that could be the problem.

Tanium inventory connection need to be created on the standalone beacon to import data from Tanium through API, beacon will upload data to FNMS-Batch Server to import into FNMS. 

From the provided log.

Running Compliance import with "-us false -processremotepackages true -it ReadersAndWriters" parameters
2020-02-20 09:25:35,544 [INFO ] Reading 'ActiveDirectory' data from 'Tanium' (ver 1.0) data source

Hope this will help.

Aamer

dcopher
Active participant

Note: Didn't mean to click accept solution on this forum. Not sure if you can Undo that.

We interpreted your response as Tanium needs to be it's own beacon. So we tried to install in on a separate beacon. The installer encounted problems as the script is referencing file paths that do not exist on a server where FNMS is not installed, just the beacon... That being said, we were able to select Tanium as a source and configure. The test on the source succeeded but when trying to run an reconcile with full import the process Locked up our Database server to where the beacon imports.

Does the Tanium connector (inventory adapter) require the FNMS base install files to operate?

0 Kudos
ChrisG
Community Manager Community Manager
Community Manager

The beacon components need to be installed on the server that you use to connect to Tanium. It sounds like you may have tried to install some other component(s) on the beacon too; I'm not sure what components you tried, but that is probably unnecessary (and from your description, doesn't work).
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos
dcopher
Active participant

We have installed FNMS and the FlexNet Beacon on the same server and successfully configured it to connect to SCCM. We need to also import Tanium data from our separate Tanium server. We initially configured the beacon on the FNMS server to connect to the Tanium server and completed a successful “test connection.” When we reconciled is where we encountered the error in the original post for “index outside the bounds of the array.”

Per the initial reply we installed the FlexNet beacon on the Tanium server instead of the FNMS batch server. We again had a successful test connection, but when we reconciled with full import the Tanium import task never kicked off and our database server locked up.

  1. Please clarify the term "standalone beacon" and what that entails.
  2. Does the FlexNet Beacon with Tanium Connector need to be installed on a separate server than FNMS
  3. The following documentation is what we followed for implementation. https://helpnet.flexerasoftware.com/FlexNetManagerSuite2019R2/EN/WebHelp/PDF%20Documents/On-Prem/FNM...
  4. Is there a document that steps through the process of implementing the Tanium connector
0 Kudos

Install FlexNet Beacon on a separate server than FNMS. FlexNet Beacon need not be installed on the Tanium Server. So, there is a server hosting Tanium, another server for FlexNet Beacon, and one more where FNMS server is installed.

Follow the steps provided in the “Installing Tanium Connector on FlexNet Manager Suite" and “Configure FlexNet Beacon to connect with Tanium" sections of this document - https://helpnet.flexerasoftware.com/FlexNetManagerSuite2019R2/EN/WebHelp/PDF%20Documents/On-Prem/FNM...

To see if you still end up facing the “index out of the bounds of the array” error, after step 6, when the Test connection is successful, skip to step 11. This should start the import and you can check the progress here - “System Health > System Tasks".

While setting up connection the to Tanium in FlexNet Beacon, what is the format of the username? Is it domain\username?

@dcopher and I have been working on this issue together. I have installed the Flexnet Beacon on a standalone server and am still receiving the same "index was outside the bounds of the array" error message.

The format of the username is simply the username. When I used the FQDN it would fail. I get a successful Tanium test connection from the beacon, but it is failing at import.

Can you please try this and see if the import works?
Create a user account in Tanium in the domainname\username format and assign this user to the "Asset Report Reader" role. While setting up connection to Tanium in FlexNet Beacon, enter this account in the domainname\username format. Test the connection and then click on Execute Now.

@sunilkumar That worked. Thanks so much for the assistance. Marked as answer.

raaron1
Active participant

@ChrisG , @sunilkumar , your guru'ness is respectfully requested. 

I've followed in the footsteps of my team mates @dbeckner and @dcopher and went through the process of bringing in Tanium inventory.

BLUF: I have successfully ran a compliance import with the Tanium connection made in the Beacon that is co-located with FNM. 

I'm confused as to the requirement that the connection be made on a different, external beacon. It does not say this anywhere in the Inventory Adapters and Connectors reference. That said, in the section called "Configure FlexNet Beacon to connect with Tanium", step 8 walks one through scheduling the connection which isn't possible on the co-located beacon. As well, step 11 has one execute which also isn't possible.

I am using the same Tanium instance as the Dans did prior (I've set up a second Destination to a different database and have yet another svc account with Asset User rights). 

Things seem to be working. So I'm thinking this is an allowable practice now (newer connector version?) and the documentation is wrong (or not updated)? 

Many thanks for your consideration,

Rob

Rob,

Steps 8 and 11 related to scheduling and Execute Now are only applicable when the beacon is not co-located. These are not applicable for co-located beacons. This is standard behavior in the beacon for inventory sources including Tanium.

I agree that the documentation can highlight these differences, when dealing with steps to follow while working with free-standing versus co-located beacons. I’ve made a note of this.