durgeshsing
Level 7

FNMS Application Configuration issue

Jump to solution

Dear Team,

I am doing fresh FNMS 2020R2 installation. I have completed DB creation successfully & When am trying to run powershell to configure application server, getting below error.

 

Any one has any idea. 

 

TITLE: Connect to Server
------------------------------

Cannot connect to fnmsdb.test.local.

------------------------------
ADDITIONAL INFORMATION:

The target principal name is incorrect. Cannot generate SSPI context. (Microsoft SQL Server, Error: 0)

For help, click: https://docs.microsoft.com/sql/relational-databases/errors-events/mssqlserver-0-database-engine-erro...

 

0 Kudos
1 Solution

None that I am aware of. I have seen this issue in a test environment a while ago. I once solved it by removing and re-joining the VM to the domain. But I think this was no permanent solution. I am really not sure what's the actual root cause for this error.

Softline Group is Europe's leading independent expert in Software Asset Management.

View solution in original post

0 Kudos
5 Replies
mfranz
Level 15

Sound like some domain stuff. Is this machine part of a domain?

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos

Yes machine is part of domain. Do we require any specific setting on domain.

0 Kudos

None that I am aware of. I have seen this issue in a test environment a while ago. I once solved it by removing and re-joining the VM to the domain. But I think this was no permanent solution. I am really not sure what's the actual root cause for this error.

Softline Group is Europe's leading independent expert in Software Asset Management.

View solution in original post

0 Kudos

Hey, Buddy

I have found the solution, I have removed not required SPN from server attribute in active directory

 

kclausen
Flexera
Flexera

@durgeshsing  - Yes, I agree with @mfranz .  If you Google your error message about SSPI Context, all of the articles indicate that this is a Kerberos authentication error.