Highlighted
Intrepid explorer

Error while configuring business adapter for Multi-tenant environment

Jump to solution

Hi All,

I am trying to configure a business adapter for multi tenant environment. Installed a standalone business adapter studio on a VM, created source connection as a csv file and destination as compliance DB. test connection is successful, but when i try to simulate i am receiving below mentioned error at the end, 

The ConnectionString property has not been initialized.

below mentioned is the command i have used to execute the adapter,

MGSBI.exe /ConfigFile="C:\BAtest\Adapter\asset.xml" /Import=Asset /TenantUID=123456789 /Log=DEBUG /LogFile="C:\Log\test.log" /Simulate

Please advice how to fix this error.

Thank you

Sasi

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Flexera
Flexera

Re: Error while configuring business adapter for Multi-tenant environment

Jump to solution

Another thought... If it is not the versions of software mentioned in my previous posts that you are using then then could you please attach the asset.xml file in a reply so we could look at that as it might give us more information that could help troubleshoot the issue. Thanks!

View solution in original post

5 Replies
Highlighted
Flexera
Flexera

Re: Error while configuring business adapter for Multi-tenant environment

Jump to solution

Hi @sasikumar_r ,

Can you please let us know what version of FNMS you are currently using and what version of MGSBI you have? There appears to be a known issue (bug) in MGSBI causing the issue you are seeing and it may be related. I would suggest opening a support request as the bug has been fixed and there is a patched version of MGSBI that can be provided if you are using the related version of the software.

The issue was seen in FNMS 2020 R1 with an MGSBI version of 15.0.0.4 and possibly 15.0.0.5.

- Bill

Highlighted
Flexera
Flexera

Re: Error while configuring business adapter for Multi-tenant environment

Jump to solution

Another thought... If it is not the versions of software mentioned in my previous posts that you are using then then could you please attach the asset.xml file in a reply so we could look at that as it might give us more information that could help troubleshoot the issue. Thanks!

View solution in original post

Highlighted
Intrepid explorer

Re: Error while configuring business adapter for Multi-tenant environment

Jump to solution

Hi @bheadley ,

You nailed it 🙂 FNMS version is 2020R1.1 and MGSBI version is 15.0.0.4.

I will raise a support case to get the updated MGSBI. 

Thank you so much!

Sasi

Highlighted
Flexera
Flexera

Re: Error while configuring business adapter for Multi-tenant environment

Jump to solution

Glad to hear that this was the issue. If the support team member has any questions tell them to reach out to me so I can point them to the other case I saw related to this which included a new version of MGSBI. They should be able to find it since I did, but I can help if needed.

- Bill