anhpham1652
Level 6

Devices failed to be inventoried

Jump to solution

Hello,

I ran "Discovery and Inventory Rules" then all devices in subnet were discovered successfully but all are failed to be inventoried. Here is the error in Status and Rule Execution Details

device status.PNG

 rule execution details'.PNG

All of devices port 135 and 445 are listening.

 I also have and only use a domain administrator account and this account is set in Beacon > Password Manager

password management.PNG

 What should I do to inventory devices? Thank you for your help.

0 Kudos
1 Solution

The error message "The system cannot find the file specified" here suggests that the target device is unable to access the following file share on your beacon: \\FLEXBEACON\mgsRET$.

A couple of possible reasons for this are:

  • The target device is unable to resolve the name FLEXBEACON to an IP address
  • Permissions on the \\FLEXBEACON\mgsRET$ do not allow the SYSTEM account on the target device to access the share
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

View solution in original post

7 Replies
kclausen
Flexera
Flexera

@anhpham1652 :

1) Make sure that the Windows RPC Service is running on the target devices
2) Make sure that you have entered the Account Credentials correctly in the Beacon
3) Make sure that on your network you don't have any Proxy or Firewall rules that block port 135 traffic

Hi @kclausen 

About the credential on Beacon, in the log before, it was "Credential="Distribution Scheduled Task User"", but now it changes to [INTEGRATED]. 

We don't use proxy or firewall or SSL

All the services and ports are running and listening

RPC.PNG

 

0 Kudos

Here is another error relating to this problem

new error'.PNG

 

0 Kudos

@anhpham1652 - I suggest you create a Support Ticket.  Remote Inventory using FlexNet Manager has a lot of network and security requirements and is not easy to configure.

i agree with @kclausen  , personally i have faced lots of issues when we tired to adopt agents using the inventory rules.

you may need to investigate at few of the inventory devices as well to understand the actual cause of the issue .

The error message "The system cannot find the file specified" here suggests that the target device is unable to access the following file share on your beacon: \\FLEXBEACON\mgsRET$.

A couple of possible reasons for this are:

  • The target device is unable to resolve the name FLEXBEACON to an IP address
  • Permissions on the \\FLEXBEACON\mgsRET$ do not allow the SYSTEM account on the target device to access the share
(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

View solution in original post

Hi @ChrisG 

Thanks for your recommendation. The targets couldn't access to that folder on Beacon. But I've got another problem. In the log from Discovery and Inventory rules, some devices are adopted and inventoried and have .ndi files. Although the tab All discovered devices, columns inventoried and agent installed is all "No".

All discovered devicesAll discovered devicesSystem task > Adoption.logSystem task > Adoption.logInventory & Discovery rules logInventory & Discovery rules logDo I have to wait until the "Inventoried" and "Agent Installed" status be updated? Or the system has something wrong?

0 Kudos