raghuvaran_ram
Active participant

DB upgrade failed

Jump to solution

We are encountering an error while upgrading the database from 2020 R1 to 2020 R2.

 

Error message : there was an error while attempting to run cm-migr1600-migpost.sql 

However, we have successfully upgraded the Inventory and warehouse database and facing issue while upgrading compliance DB.

 

Regards

Raghu

 

 

1 Solution

Accepted Solutions
raghuvaran_ram
Active participant

Re: DB upgrade failed

Jump to solution

@mfranz 

I have raised a case and the solution provided was very similar to what you suggested, I was asked to delete only that specific entry that was causing the error, so post that I was able to complete the upgrade successfully.

exec BeaconTargetRemoveByNameInternal 'Known virtual cluster servers', 1
DELETE FROM BeaconTarget_MT WHERE [Name] = 'Known virtual cluster servers'

Thanks to everyone who replied to this query.

View solution in original post

8 Replies
mfranz
Shining star

Re: DB upgrade failed

Jump to solution

Looks like the migrations steps would like to insert existing values into the BeaconTarget_MT table. If you remove all entries from this table, the migration script should insert everything with new IDs.

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos
raghuvaran_ram
Active participant

Re: DB upgrade failed

Jump to solution

@mfranz 

 

Thanks for your reply,

 

Do you mind helping me in sharing the query to find the table?

0 Kudos
mfranz
Shining star

Re: DB upgrade failed

Jump to solution
USE FNSMCompliance

SELECT *
FROM BeaconTarget_MT

As you're in the middle of a migration, I assume you have database backups 😉

Softline Group is Europe's leading independent expert in Software Asset Management.
0 Kudos
raghuvaran_ram
Active participant

Re: DB upgrade failed

Jump to solution

@mfranz 

 

Yes. I'm testing this upgrade in the backup DB. I have deleted the entries in the entire table and retriggered the upgrade and it got completed successfully, but it did not bring back all the items. Attached the screenshot for your reference.

 

I have lost all the custom targets used for rules, I have attached the before and after screenshot for your reference, is there any other option as I need to have all those targets when I do the same activity in production.

0 Kudos