cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cognos installation getting error at final stage

Hi,

PFA, While installing the Cognos on final stage getting below error. IBM Cognos service also not able to start. 

Please help on this.

Invoke-CognosConfigTool : Exception calling "Invoke" with "2" argument(s): "Cognos configuration failed (error code 2). Check the cogconfig.*.log and cogconfig_response.csv files found in
E:\Program Files\ibm\cognos\analytics\logs for more information."
At C:\temp\FNMS 2022R1\Support\modules\ConfigureCognos.psm1:160 char:2
+ Invoke-CognosConfigTool $CognosInstallDir -ErrorHandler ${functio ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Invoke-CognosConfigTool], MethodInvocationException
+ FullyQualifiedErrorId : RuntimeException,Invoke-CognosConfigTool

 

Thanks,

Sreerama Yenuga

0 Kudos
10 Replies
kclausen
Level 15 Flexeran
Level 15 Flexeran

@sreeramyenuga - As stated in the error message, you will find additional information in the native Cognos log files found in E:\Program Files\ibm\cognos\analytics\logs:
  cogconfig.*.log
  cogconfig_response.csv

0 Kudos

Hi @ kclausen,

I tried to start the IBM Cognos service manually but didn't start. PFA, Sharing the logs any idea from your side.

Thanks,

Sreerama Yenuga

0 Kudos

It looks like these files don't give much detail about a specific cause of why Cognos can't start. However the following line in the cogconfig_20220915_122819.log file looks suspicious:

{} = {} platformserver.host http://Hostname

I think this suggests you are configuring Cognos with the URL "http://Hostname" for connecting to your FlexNet Manager Suite server. Is "Hostname" really the name of that server? That would be an unusual name to use on a network.

I'd suggest looking around for other log files that Cognos has created to see if they give you any insight.

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)

@ChrisG 

i removed the FQDN NAME just append the "host name" in the log.

PFA, attached cognosserver log showing errors.

Thanks,

Sreerama Yenuga

0 Kudos
lajanakiram
Level 5 Flexeran
Level 5 Flexeran

Hi @sreeramyenuga , 

This occurs if the SQL Server is configured only to use TLS 1.2? If only TLS 1.2 is enabled then follow the below article.

https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/Analytics-Cognos-connection-to-SQL-server-fails-when-server-is/ta-p/113351

0 Kudos

Hi @ lajanakiram,

As followed by given URL but no luck. Unable to start the IBM Cognos Service.

Thanks,

Sreerama Yenuga.

0 Kudos

Hi @sreeramyenuga , 

What is the error? Also share the log files.

0 Kudos

Hi @ lajanakiram,

PFA, Please let me know if anything required.

Thanks,

Sreerama Yenuga.

0 Kudos

Hi @sreeramyenuga , 

ERROR, "[Start Service]", "CFG-ERR-0103 Unable to start IBM Cognos service.
Execution of the external process returns an error code value of '-1'."

Can you please try the below step of updating the password in Services.msc and try starting the cognos service via CogConfig.bat executable from configuration folder.

https://www.ibm.com/support/pages/cfg-err-0103-unable-start-cognos-service

0 Kudos

Dear @  lajanakiram,

We did this but still facing same issue. Might be port issue we are suspected.

Thanks,

Sreerama Yenuga.

 

0 Kudos