Some users may have issues creating a community account. For more information, please click here.

carlos_quiros
Occasional contributor

Cognos/Analytics Single Sign On

Hi, 

Have anyone seen this error? 

"Connection to the Database with Single Sign On Failed"

This is when I try to launch the Analytics Home Page for pre-loaded reports. 

The user that I'm currently using it's part of the "Business Reporter Admin Role"... No errors or issues when installing the tool.

I'm attaching an screen shot with the error.

Thanks for any help.

0 Kudos
16 Replies
kclausen
Flexera
Flexera

@carlos_quiros :

Verify that the TCP/IP network protocol is enabled for the SQL Server instance that is hosting the ContentStore database

Verify that the Service Account that is running the IBM Cognos service is the DBO of the ContentStore database

carlos_quiros
Occasional contributor

@kclausen ...thanks for your response.. 

I checked this already, TCP/IP is enabled and user it's DBO of the ContentStore database. 

Thanks and still looking for some other options. Appreciated

0 Kudos

In the IBM Cognos Configuration utility, under Data Access > Content Manager > Content Store, right click on this and Test the connection, does this fail? This should be the connection that it is referring to when loading the widget data. 

0 Kudos

@WheresThePizza thanks for your reply. The connection succeeded from there.  

The issue it's actually when trying to load the reports.  I'm attaching a couple of screen shots for reference. Thanks again for your help.

0 Kudos

The second error seems to indicate that this is a connection issue with the driver Cognos is using, and the SQL server. Is your SQL server currently configured to use TLS? If this is the case, then you may just need to follow the steps to configure Cognos to support TLS, including modifying the JVM argument for the QueryService to work with TLS. We have this KB that discusses this:
https://community.flexera.com/t5/FlexNet-Manager-Knowledge-Base/Analytics-Cognos-connection-to-SQL-s...

0 Kudos

@WheresThePizza thanks again for your help with this. 

Actually, that's the document that I used to be able to install the tool. I was having the issue when trying to connect from Cognos Configuration - Content Store. It wasn't connecting and after following that document I was able to established a connection. But for some reason the issue it's now with the portal itself. 

I did also followed the attached document but the issue keeps persisting. 

Any other help it's much appreciated

0 Kudos

If you went though the KB, did you do the steps outlined in the IBM KB? Specifically these:

To get the JDBC data source connection working:

 
- Go to Cognos Administration -> Configuration tab -> Dispatchers and Services
- Click on the dispatcher server to drill down to the services
- Beside the QueryService, click the Set Properties button
- Go to the Settings tab
- Add the following the Additional JVM Arguments for the QueryService setting
 
-Dcom.ibm.jsse2.overrideDefaultTLS=true
 
- Click OK
- Click on the Status tab
- Select System
- Click on the server to drill down to the services
- Beside QueryService, click the drop down arrow
- Select "Stop immediately"
- Wait 30 seconds for it to fully stop
- Click the drop down again and select "Start immediately"

If you did the rest of the steps, the test connection would work, but the widgets and reports still may not load the data, as the QueryService needs to have the JVM argument added to support TLS. 

@WheresThePizza ... I didn't performed this step that you mentioned. For some reason I missed it. Thanks for bring it on. I just discovered that the service is missing from the services. Please take a look on attached picture. 
Unless that I'm on the incorrect place I cannot seem to find the service anywhere. Thanks for all your help and responses. 

0 Kudos

@WheresThePizza sorry I just found the service... let me keep following the solution and I will let you know the results... regards,

0 Kudos

@WheresThePizza  ... I think here's where the issue can be. For some reason I'm missing tabs for the QueryService. Same happen on the rest of the services. As per the solution I should be able to see a settings tab and some more other options that are not within this service. Attaching an screen shot as reference. Thanks

0 Kudos

If you do not see these options you will want to open a support case so someone from the support team can help. They are missing because of they way permissions are provisioned for FNMS. These views require having a system administrator account. To rectify this you would need to modify a user entry in the Content Store database. Given the nature of what is involved to accomplish this, we provide these steps through a support case as opposed to public forum or KB articles. 

0 Kudos

@WheresThePizzathank you so much for all your help and support on this. Much appreciated

0 Kudos

Hy @carlos_quiros  @WheresThePizza 

could you please share the solution how to get the "settings tab" back to cognos. I'm running into the same problem and as already discussed and would like to change the dispatcher settings to connect to the ContentStore DB.

 

Thanks and Best, Dennis

0 Kudos

Hi @dennis_reinhardt 
as  @WheresThePizza mentioned, service account used must have full system administrator rights on Analytics and I also suggest you to work over the case with them. As these steps could be different for different environment. Also make sure to get the ports working before hand, I faced this issue couple of months back and Flexera team was able to help me over the support.

Thanks 

0 Kudos

Hi @sushant_narula 

The appropriate settings and permissions are all in place. It really only fails at the connection to the FNMS database as in the screenshot of @carlos_quiros  and is due to a problem with TLS1.2, which can be solved by an adjustment via the "Settings Tab" in Cognos.

Although the problems and approaches may be different, the community would greatly appreciate your solution so that others with the problem can get to a solution faster.

Thanks and regards,
Dennis

0 Kudos

Due to the nature of what is involved in elevating a user to the admin level required to expose these settings, we cannot publicly share these steps. Doing so could allow Cognos users (not just Flexera Analytics users) to gain admin access where they should not be able to. In this regard, these steps are only provided through support cases.