Showing results for 
Show  only  | Search instead for 
Did you mean: 

Client Uplaoder Log says Failed to upload to beacon

Error 0xE0AF000C: Failed to obtain Domain Controller name for NULL Site (Error=0x54b)
Error 0xE0AF000C: Failed to obtain Domain Controller name for NULL Site (Error=0x54b)
Error 0xE0500005: Host name lookup failed
Error 0xE050044D: Failed to create remote directory /ManageSoftRL
 Error 0xE0690099: Specified remote directory is invalid, or could not be created
ERROR: Remote directory is invalid
Upload failed due to a client connection issue. This server will not be retried during this upload session.

Please suggest how can I fix this issue?

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

6 Replies
Flexera Alumni

Hi @chirag_sharma2,

The error 'Host name lookup failed' suggests a potential DNS issue.

Once you know which beacon it tried to upload to, I'd suggest opening an administrative CMD window and running nslookup from the agent device, to see if it is able to resolve the beacon's FQDN to the correct IP address:

nslookup <beaconFQDN>

If my response answered your question satisfactorily, please click "ACCEPT AS SOLUTION" to heighten visibility for future customers!
0 Kudos

Hi @chirag_sharma2 ,


I agree with @jjensen , as I had exactly the same issue with some DMZ servers which don't have DNS. The solution was to update the hosts file on the server and encoding there the ip and FQDN of the beacon servers. 


I tried with nslookup and tracert from client machine and it is connecting/showing same IP and FQDN.

I have SSL cert installed

0 Kudos

Hi @chirag_sharma2 ,

When you check the log file, do you have the like this:

Download FAILED for “http://Policies/Merged/

OR like this:

Download FAILED for “http://<your beacon neame>/Policies/Merged/

The difference is that the 1st error is then you install the agent with no configuration file, and then the agent will not know from where to download the policy

The 2nd option is when you installed the agent with the correct configuration file but the DNS is not resolving the FQDN.

If you tested from the client machine and the tracert and nslookup looks fine, then I would suggest to reinstall the agent on the server, making sure the configuration file is correctly and running the install as administrator. 


0 Kudos

For the agent running on Windows server without DNS set up, how can I configure nslookup to look at hosts file to resolve host name?

0 Kudos


You don't need to configure nslookup, you simply modify the host file located in