cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

BeaconEngine.log file not truncating

I just noticed on one of our beacon servers, that the BeaconEngine.log file has just been growing for the last couple of months. Prior to this, a new file was generated every day and each were a little over a megabyte. The current file is over 100mb and is just growing every day. 

How do I get the log to go back to the previous behavior of a new one generating every day? I searched the manual and forum but had not luck finding what may be a simple answer. Thank you!

(1) Solution

Hi @dnunziato,

What you are describing sounds like the following known issue:
https://community.flexera.com/t5/FlexNet-Manager-Suite-Known/FlexNet-Manager-Suite-Flexera-One-ITAM-Known-Issues/ta-p/190476?filter=%20%20%20IOK-1030675

You may find that the Beacon exhibiting this behavior is missing the archiveEvery="Day" parameter within the BeaconEngine.config file located under C:\ProgramData\Flexera Software\Compliance\Logging

You could compare this config with the config file of your other Beacons or simply add archiveEvery="Day" to the section within the config file where the "archiveNumbering" element is present and then restart of the beacon engine service.

Regards

Vas

View solution in original post

(2) Replies

Hi @dnunziato,

What you are describing sounds like the following known issue:
https://community.flexera.com/t5/FlexNet-Manager-Suite-Known/FlexNet-Manager-Suite-Flexera-One-ITAM-Known-Issues/ta-p/190476?filter=%20%20%20IOK-1030675

You may find that the Beacon exhibiting this behavior is missing the archiveEvery="Day" parameter within the BeaconEngine.config file located under C:\ProgramData\Flexera Software\Compliance\Logging

You could compare this config with the config file of your other Beacons or simply add archiveEvery="Day" to the section within the config file where the "archiveNumbering" element is present and then restart of the beacon engine service.

Regards

Vas

Hello @Vmintzikos 

That appears to have worked! Thanks for pointing that out to me.