bmaudlin
Consultant

Automatically upgrading agent v13.0.1 to v16

Hi Guys,

I'm just trawling the documentation currently, however I thought it may be quicker to ask here. Our current agent v13.0.1 has gone out of normal support, and I am exploring options of how to upgrade this agent.

Does v13.0.1 support an upgrade via a deployment from the inventory beacons to v16?

Ben

0 Kudos
5 Replies
durgeshsing
Frequent contributor

I have done Upgrade from 13.1.1 to 16.0 & its working fine.

I would suggest follow below step

 

1:-Try to install agent manually & see if its removing old client & installation new. Also verify if its reporting fine in fnms. If this test goes well then it should work for auto upgrade as well.

2:-Auto Upgrade will work for default installation directories if previous version has custom installation location then it will not work. Also please ensure NO third party deployment has schedule for old agent like SCCM or GPO.

3:-If above two points are ok then go head & target 3-4 device & check the result.

4:- If above 3 points goes well then you are good to go.

 

 

 

@durgeshsing  - thanks for the update.

Would this be the same process for the Unix based agents? Not 100% sure if there is an upgrade path for those agents.

Ben

0 Kudos
durgeshsing
Frequent contributor

Yes. 

0 Kudos

Ahh okay, so there is no need to remove the Unix based agent prior to upgrade, my understanding was the agent needed to be fully removed on Unix based OS prior to install, to then install the new agent. Is this not the case?

0 Kudos
ChrisG
Community Manager Community Manager
Community Manager

There's no need to uninstall the agent on UNIX prior to upgrading it, unless you want to change the installation location.

However on a semi-related note, do be aware that there are some complexities and variations between UNIX-like operating systems with agents installed to a non-default location. The key considerations (copied from Agent third-party deployment: Installing FlexNet inventory agent on UNIX) are:


For some UNIX-like platforms, you can customize the command line to install the FlexNet inventory agent in the folder of your choice. Because FlexNet Manager Suite uses the native installation technology on each platform, this introduces some diversity into the installation process, as described below. As well, notice the following points:
  1. If you previously had the FlexNet inventory agent installed in the default location, and now wish to switch to a custom installation path, first uninstall the old agent.
  2. With a customized installation path, support for in-place self-upgrade of FlexNet inventory agent requires:
    • The installed, running version of FlexNet inventory agent must be 13.2.0 or later, with a later version specified as the intended upgrade
    • The installation is on either AIX or Linux.
    For other platforms, or when an earlier version is operational, using third-party deployment to a custom location means that you are also committing to update the FlexNet inventory agent in that location using your chosen third-party technology.
  3. If you previously turned on self-upgrade of the FlexNet inventory agent (and are now switching to a custom installation path with third-party deployment), you should typically navigate to Discovery & Inventory > Settings. In the Inventory agent for automatic deployment section, consider selecting Do not upgrade automatically and publishing this setting for platforms where you are implementing the custom installation path. While it is possible to use a third-party tool for deployment, and then allow in-place self-updates, this requires very careful management so that, for example, you do not allow the third-party tool to continue maintaining one installed version at the same time as the self-update policy requires a different version. A difference in policy can mean that one tool upgrades and the other tool downgrades again (or attempts to). This tussle for control can result in damaged installations and a non-functional FlexNet inventory agent.

Currently, a custom installation folder is supported for the following platforms:

  • AIX version 5.3 or later, where the custom path is called a User Specified Installation Location (USIL)
  • Linux x86 (RPM)
  • Linux x86_64 (RPM)
  • Solaris SPARC (currently does not support in-place self-upgrade)
  • Solaris x86 (currently does not support in-place self-upgrade).



 

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)