cancel
Showing results for 
Search instead for 
Did you mean: 

What could cause an Incompatible FlxCore64.dll error message on only one of multiple similar Dev systems?

No ratings

What could cause an Incompatible FlxCore64.dll error message on only one of multiple similar Dev systems?

Summary

What could cause an Incompatible FlxCore64.dll error message on only one of multiple similar Dev systems?

Question

FlexNet Embedded (FNE) 2016.03 is giving the following error on one of our dev?s machines ?Incompatible FlxCore64.dll?. The problem machine is running Windows 7 64 Bit system and we're compiling and linking the same way as well. Understanding that FlxCore64.dll is neither forward nor backward compatible, we've verified that all components involved are using the same version of FNE (same md5sum). What are the conditions under which this error is printed from FlcErrorGetMessage()?

Answer

Two possible reasons include:

1. You may be pulling a different version of FlxCore64.dll than you think you are.

2. The tamper resistant architecture code in FlxCore64.dll is detecting a tamper condition. In FNE 2017.02 better reporting of tamper conditions was added, while prior to that release tamper conditions often exhibited as ?Incompatible FlxCore?? errors.

Additional Information

Tamper detection logic includes two things:

1. Validating the DLL is still signed and that the signature has not been compromised.

2. Checking that there has not been any tampering with the dynamic memory of certain sections of the DLL. Bear in mind that setting a breakpoint on any instruction with a debugger within the FlxCore code is flagged as tampering, as would hooking any calls from within the FlxCore DLL.
Was this article helpful? Yes No