cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

FlexNet Connect Installer Transform Utility

FlexNet Connect Installer Transform Utility

Summary

When running an MSI containing the FLEXnet Connect merge modules (versions 6.0 to 11.6) you may encounter certain installation problems.

Symptoms

When running an MSI containing the FlexNet Connect merge modules (versions 6.0 to 11.6) you may encounter certain installation problems. In particular you may see the following error:

Error 2753.The File 'agent.exe.6ED28686_7B19_420C_B255_5B6C1BD2C705' is not marked for installation.

Error 2753.The File 'isuspm.exe.6ED28686_7B19_420C_B255_5B6C1BD2C705' is not marked for installation.

*Note the guid appended to the file names will differ depending on the version of the merge module being used.

Or alternatively, the install may appear to complete successfully; however, the product may not be registered on the target machine.

Neither of the issues are critical, as the install should complete successfully; however, the product will not have been registered with the agent on the machine. Any of the product?s subsequent calls to check for updates will then result in errors


Cause

Both issues are due to the way the product/version registration custom actions are configured. The underlying cause is that when your installer encounters newer versions of the client files already on the target machine, the MSI will not install/overwrite the newer agent with the older agent/client files. This prevents a custom action from being run.


Resolution

These issues have been resolved with later versions of the merge module and the attached exe modifies older installs to resolve these issues. Newer versions (12.0 and later) of the FlexNet Connect merge module use a different type of custom action and a different condition on the custom action.

The attached utility transforms your built installation package and removes installation problems associated with the FLEXnet Connect merge modules.

* Note: As the exe modifies the existing MSI, we recommend backing up the file before using this utility.

To transform your installation package

1. Launch the attached exe.

2. Browse for your MSI or setup.exe.

3. Click Run.

Alternatively you can drag your MSI or setup.exe file directly onto the exe using Windows Explorer.

The utility transforms the MSI, modifying the CustomAction and InstallExecute tables to resolve the issues mentioned above.

Running this exe against an MSI that does not suffer from the symptoms mentioned will not adversely affect the package in any way.

NOTE: The attached FNC+XForm.exe utility is intended to make it easier to apply the required transform to the affected setup.exe or .msi file. On certain machines, it has been noted that the that the utility will not be able to apply the transform correctly to a setup.exe file (no problems have been reported when using a .msi). If, after attempting to use the utility with a setup.exe, a problem is encountered, then it is possible (and necessary) to apply the transform manually, without using the FNC+XForm.exe utility. To apply the transform manually to a setup.exe, perform the following steps:
1. Create the directory c:\transform, on the machine where the product is to be installed.
2. Copy the attached public_fnc.mst to c:\transform
2. Run the following command line:
setup.exe" /v"TRANSFORMS=\"c:\transform\public_fnc.mst\""
Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Jan 25, 2010 04:20 PM
Updated by: