cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Symptoms:

The Normalize process fails during the Analyze load phase with the below error in bdna.log:

ERROR System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Exception: Analyze data load failed. ETL: [inv_id] Message: [There is already an object named 'TMP_AGG_N_IT_ASSETS' in the database.]

Root Cause:

This issue is caused by the ETL Timeout (default timeout is 12 hours), if the data load for aggregate tables takes longer than 12 hours.

Workaround:

Change the the default ETL timeout from 12 hours and set it to a higher value (eg: 48 hours).

NOTE : This does not mean your ETL load will actually run for 48 hours each Normalize process.

It only means that the process will force cancel the ETL load if it has still not completed in 48 hours.

Steps:

1)Stop User Console service.

2)Take a backup of the file: <User Console Install Folder>\Conf\NBI.Configuration.config

3)Open file: <User Console Install Folder>\Conf\NBI.Configuration.config


Add a new Element under  Node <Configuration>

<ETLTimeout>48</ETLTimeout> 

4)Save this file.

5)Start User Console service.

6)Re trigger your Normalize job.

 

NOTE : We have made some performance improvements in v 5.5.28 for some of the Aggregate tables which helps reduce the ETL load time.

However, this workaround maybe used on any product version above 5.5.22.

Was this article helpful? Yes No
No ratings
Version history
Last update:
‎Apr 08, 2020 06:43 PM
Updated by: