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Symptoms:

BDNA upgrade has succeeded on applying 5.5.22_DLLS.zip file, but failed at applying User Console patch - 5.5.22_Analyze_NBIDLLS.zip file.

Diagnosis:

1. Check logs if 5.5.22_DLLS.zip has been applied successfully.

 

2. Check the version of bms.common.dll in both Data Platform/bin and User Console/bin folder. The version is expected to be different due to the upgrade failure.

 

3. User Console cannot be connected in Admin UI

 

Solution:

1. Please DON'T re-run User Console Config Wizard when this error occurs

 

2. Please make sure "FIPS" is disabled on the local security policy group

 

3. Follow the below steps to manfully apply the patch set - 5.5.22_Analyze_NBIDLLS.zip

 

1. Connect to User Console Server, and run CMD as administrator
2. Enter to ‘the-patch-to\User Console\Bin’
2. Run command line 
Updater.exe /file="Path-to\Use Console\tmp\ 5.5.22_Analyze_NBIDLLS.zip"

 

4. When #2 completes without errors, then go to admin UI to activate User Console (you may want to check if User Console UI works first, if see license related error, please file a new case for a new analyze license)

 

5. Connect to BDNA database and run below query to waive the patch set - 5.5.22_Analyze_NBIDLLS.zip out from RED BANNER in Admin UI

 

1. For SQL setup
update nbf_sys_files set status='NONE' where file_name like '5.5.22_Analyze_NBIDLLS%';

2. For Oracle setup
update nbf_sys_files set status='NONE' where file_name like '5.5.22_Analyze_NBIDLLS%';
commit;

 

7. Go to Admin UI and re-apply the remaining patches.

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Comments
goody612
By
Level 8

Is this related to the user console config failing at starting the User Console service?

gliu
By Level 7 Flexeran
Level 7 Flexeran

No, this is for patch set applying failure. This failure will also results in config failing at starting the User Console service.

Version history
Last update:
‎Dec 13, 2019 01:04 PM
Updated by: