Upgrader requires WMI Access

Upgrader requires WMI Access

Summary

The Upgrade utility requires WMI Access. This is implied as Application Admin in SCCM 2012, but must be manually given in SCCM 2007.

Synopsis

The Upgrade utility requires WMI Access. This is implied as Application Admin in SCCM 2012, but must be manually given in SCCM 2007.

Discussion

The Upgrade utility requires WMI Access. This is implied as Application Admin in SCCM 2012. As SCCM 2007 did yet implement the user role scheme for permissions, WMI access must be manually implemented. The following error will be observed where WMI access is not configured:

11/01/2015 12:45:28 PM> Upgrading Database
11/01/2015 12:45:28 PM> Connection opened for upgrade
11/01/2015 12:45:33 PM> Error Encountered: Access denied

To confirm WMI access, refer to the following MSDN documentation: https://technet.microsoft.com/en-us/library/bb932151.aspx

Labels (1)
Was this article helpful? Yes No
No ratings
Version history
Revision #:
1 of 1
Last update:
‎Nov 07, 2018 05:48 PM
Updated by: