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Summary

The error is encountered when accessing the admin security or catalog security tab

Symptoms

The following error might be encountered when accessing either of the following tabs:
Admin | Site Management | Admin Security
Admin | Site Management | Catalog Security tab
Server Error in '/ESD' Application.
The source contains no Datarows.

Cause

The error is caused when App Portal attempts to load an invalid Admin security mapping or Catalog Security mapping stored in the App Portal database. This can happen when an Active Directory user or group that is currently mapped in the database is no longer valid in Active Directory.

Workaround

To workaround the issue, make a backup copy of the database and run the following SQL queries against the App Portal database to remove all the current security mappings. You can then repopulate the security mappings with valid Active Directory entries.

If the error occurs under the Admin -> Site Management -> Admin Security tab, run the following SQL query:
delete from WD_NodeSecurity

If the error occurs under the Admin -> Site Management -> Catalog Security tab, run the following SQL query:
delete from WD_CatalogSecurity

After the manual database update, do an IISRESET on the App Portal Server.
Log in to the App Portal site and repopulate the security mappings with valid Active Directory groups/users.

Additional Information

This issue has been fixed in App Portal 2015 R2 where the invalid Active Directory entry is shown as a blank account and can be deleted by the administrator account.
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Version history
Last update:
‎Nov 07, 2018 06:47 PM
Updated by: