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No Strings are Displayed on My Apps Page After Upgrade to App Portal 2017 R2

No Strings are Displayed on My Apps Page After Upgrade to App Portal 2017 R2

Summary

After upgrading to App Portal 2017 R2, no English strings are being displayed under the MyApps page.

Symptoms

After upgrading to App Portal 2017 R2, no English strings are being displayed under the MyApps page... The following screen capture illustrates the missing strings:

User-added image

Cause

The App Portal installer inserts a duplicate string into the WD_localizations table, where the strings are stored. This duplicate string prevents the English strings from rendering properly on the page.

Workaround

To work around the issue, it is necessary to delete the duplicate string. To delete the duplicate string, run the following query against the App Portal database.
if ((SELECT COUNT(*) from WD_localizations where resourceid like 'AdminUninstall' and LocaleId = '') > 1)
       delete top(1) From WD_Localizations where resourceid like 'AdminUninstall' and LocaleId = ''

After deleting this string, it is necessary to perform an iisreset on the App Portal server.
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Version history
Last update:
‎Oct 18, 2018 06:18 PM
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