Display Name on Welcome Page if Display Name in Not Found for a User in App Portal

Display Name on Welcome Page if Display Name in Not Found for a User in App Portal

Summary

If a DisplayName is not found for a user, the following steps can be taken to ensure a name is configured correctly.

Symptoms

If a DisplayName cannot be found for a given user, "Not Defined" will be displayed as the user's name on the welcome page in App Portal.

For example:
User-added image

Cause

Most often, a DisplayName has not been defined for the user within Active Directory.

Resolution

1) Confirm the account in question has a DisplayName defined in Active Directory
2) Confirm the account in question has a DisplayName that has been synced by running the following query against the AP database:
select Email,UniqueName,DisplayName from WD_User
Alternatively, you can view the list of synced users from within the Admin section under Site Management | Imported Users and Computers.

3) Confirm that DisplayName has been extended in SCCM: http://helpnet.flexerasoftware.com/appportal2015R2ig/default.htm#helplibrary/AP_ADAttribute.htm?Highlight=displayname

If you find that is not been extended already in SCCM or that a name must be entered in to Active Directory, you must run a User Discovery in SCCM after enabling it. After that completes, you will then need to run the Data Sync in App Portal to pull the latest information from SCCM.
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‎Oct 19, 2018 05:16 PM
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