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Symptoms: 

App Broker reports that the request has failed, but Config Manager is reporting that the software was successfully deployed. 

 

Diagnosis:

By default, App Broker will immediately fail a request, if a failure status is written to the Config Manager database. App Broker does not continue to monitor the request. Config Manager attempts to reinstall, and the subsequent attempt is successful, but App Broker does not pick up on this fact as the status for the request is no longer being monitored.  

Solution:

App Broker provides a setting named "Monitor threshold for failed deployments to prevent false flags" under Site Management -> Settings -> Timers.  If this is set, then App Broker will continue to monitor the status for a failed request for X hours, where X is the number of hours specified for the setting. If no success status is received after this period of time, then a "final" failure will occur, and no further status checks will be made. If, however, a success status is received during this time, then the status of the request will be changed to successful. 

Generally, setting "Monitor threshold for failed deployments to prevent false flags" to 24 hours is sufficient to allow Config Manager to make an attempt to reinstall. 

For additional information please see How App Portal Responds to Failure Statuses Received from System Center Configuration Manager.

 

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Last update:
‎Dec 29, 2021 02:30 PM
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