mqmathews
Occasional contributor

App Survey

Jump to solution

HI Team,

I was under the impression that I could use app survey for the following OS wipe and load upgrade activity without manual intervention or swapping computers. I completely understand I can use clone migrate when we need to change the users computer. In this case I am looking for the user to keep the same computer. Can you help with instructions if it is possible.

Here is a high level overview as I thought it works. Just not sure the steps in app portal to achieve it.

1) Take an inventory of the applications on computer xyz.

2) Format the hard drive and load windows 10 (the computer previously had windows 7)

3) Install the applications on computer xyz.

 

Thank you in advance

0 Kudos
1 Solution

Accepted Solutions
CharlesW
Flexera
Flexera

Re: App Survey

Jump to solution

I don't think that you would necessarily need App Survey to apply install applications after an in-place OSD.. A better approach would be to use the built-in functionality for migrating existing Applications, as seen in the admin guide at Choosing Existing Applications to Migrate During an OS Deployment. In addition to selecting the "Enable application migration and installation of additional applications option" under the Settings -> Deployment -> OS Deployment tab, you also need to be sure to select the "Auto Detect Installed Apps" checkbox found under the Deployment->Roles tab of your TS catalog item. On your TS catalog item, be sure that you also select "Apply Computer Variables (Task Sequence)" under Deployment->Global. 

Also, it should be noted that only those catalog items which are associated with an inventory group or a Flexera ID, and which have "show for clone/migrate" will be available for migration. Obviously, the items must also be installed on the device. 

NOTE: I know that there was an issue with the "choose existing applications" panel not showing up during checkout, if using a request on behalf of checkout, so if you are using request on behalf of, then you need to be sure that you upgrade to 2018R1, as the issue was fixed in this release.

View solution in original post

7 Replies
mqmathews
Occasional contributor

Re: App Survey

Jump to solution

yes, I read those weeks ago. They don't address the situation described!! Now I am trying to use task sequence deployment with Dynamic app deployment. as described in the OS deployment section. I found at least one issue in my ask sequence.

0 Kudos
CharlesW
Flexera
Flexera

Re: App Survey

Jump to solution

I don't think that you would necessarily need App Survey to apply install applications after an in-place OSD.. A better approach would be to use the built-in functionality for migrating existing Applications, as seen in the admin guide at Choosing Existing Applications to Migrate During an OS Deployment. In addition to selecting the "Enable application migration and installation of additional applications option" under the Settings -> Deployment -> OS Deployment tab, you also need to be sure to select the "Auto Detect Installed Apps" checkbox found under the Deployment->Roles tab of your TS catalog item. On your TS catalog item, be sure that you also select "Apply Computer Variables (Task Sequence)" under Deployment->Global. 

Also, it should be noted that only those catalog items which are associated with an inventory group or a Flexera ID, and which have "show for clone/migrate" will be available for migration. Obviously, the items must also be installed on the device. 

NOTE: I know that there was an issue with the "choose existing applications" panel not showing up during checkout, if using a request on behalf of checkout, so if you are using request on behalf of, then you need to be sure that you upgrade to 2018R1, as the issue was fixed in this release.

View solution in original post

mqmathews
Occasional contributor

Re: App Survey

Jump to solution

Charles,

Yes, I do believe this to be the correct path. I found this after posting the question. On the 8-22-2019 I was nearly there just has an issue in the task sequence I needed to resolve. The task sequence is not installing the dynamic software list of software. I get a task sequence error 0x80004005. I am using 2019 r1 with manual software inventory. if you have any suggestions that would be great!

0 Kudos
CharlesW
Flexera
Flexera

Re: App Survey

Jump to solution
Specific task sequence errors would be outside the realm of my expertise. I did google the problem and came up with a number of hits. You might look at the following post:

https://social.technet.microsoft.com/Forums/en-US/d774aa93-ebf9-4693-9480-c02ce13d859f/error-0x80004...
0 Kudos
jdempsey
Moderator Moderator
Moderator

Re: App Survey

Jump to solution

The error code you have cited is a "generic error".  There could be many different causes for such an error.  You would have to look at the smsts.log for more detailed information regarding the error.  There are many resources in the Microsoft community regarding troubleshooting of task sequences.  In particular, Johan Arwidmark, Michael Niehaus, and many ConfigMgr MVP's have published presentations and blogs on OSD troubleshooting.

Anything expressed here is my own view and not necessarily that of my employer, Flexera. If my reply answers a question you have raised, please click "ACCEPT AS SOLUTION".
mqmathews
Occasional contributor

Re: App Survey

Jump to solution

jdempsey,

Yes the error message is practically useless. last night I dug thru the logs and I think I found the real error. It is not finding the packages. I am doing research now. I will look at the authors that you suggest thank you for your input this is way out of my skill set.

0 Kudos