Select Tests To Execute Causes Unhandled Exception in AdminStudio

Select Tests To Execute Causes Unhandled Exception in AdminStudio

Summary

Error occurs using Select Tests to Execute when there are custom tests applied

Symptoms

Select Tests to Execute button result in an error in AdminStudio when you click on the Select Tests to Execute button it will result in a .NET Just In Time error. The problem reads:
Unhandled exception has occurred in a component in your application. If you click Continue, the application will ignore this error and attempt to continue.


Reference screenshot:

Unhandled exception using Select Tests to Execute

Cause

This can be caused by custom test entries in the dbo.ASTestCategory table. The problem has been known to occur when specifically upgrading to AdminStudio 2018 SP2. When these custom test records are cleared out, then the problem will no longer occur.

Steps To Reproduce

  • Using AdminStudio 2018 R2 connect to the database.
  • In Application Manager go to Analyze > Select Tests to Execute

Resolution

This issue has been reported to the development team and is currently being tracked under issue number: IOJ-1890197


Workaround

Specific change to the AdminStudio database resolves the issue. Before removing these entries back up the table entries to a SQL script and ensure you have a backup of the database.
  • Close AdminStudio
  • Back up database and table entries
  • Manually edit the SQL database by running:

DELETE FROM dbo.ASTestCategory WHERE "Name" LIKE '%Custom%'
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Last update:
‎Oct 19, 2018 03:36 PM
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