Notifications And\Or Permissions Are Not Behaving Correctly.

Notifications And\Or Permissions Are Not Behaving Correctly.

This article details the workaround for when Workflow Manager notifications and\or permissions are not behaving correctly.

Symptoms

Email Notifications in WFM(Workflow Manager) may not be being sent correctly for certain Phases or Steps.
Permissions for certain Phases or Steps may not be correctly behaving.

Cause

This is caused by bugs in the software that cause the Database Tables to be out of sync.

The AMS_TemplateRole and AMS_ItemRole tables may not match correct values for Permission and Notification related columns.

Workaround

Run these scripts attached to this article:
1_Duplicates_Deletion.sql
2_Reset_Permissions.sql

After running scripts, further changes to notifications or permissions could cause the database to be out of sync again.
This may require the scripts to be run again.

Upon running scripts beyond the first time will require the renaming of backup tables created in the SQL database:
AMS_ItemRole_Back
AMS_TemplateRole_BACK

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Last update:
‎May 08, 2019 07:59 AM
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