Showing results for 
Show  only  | Search instead for 
Did you mean: 

issue with AppData folder

I repackage my application and created MSI file using Admin studio 10.0.
I have one issue in application after installation when we launch application, "Check for update" menu item should be disable. For this i have created GlobleOOption.xml file with checkforupdate tag to false. Now when we install application with this modified xml file in AppData folder. "Check for update" was disable now. But for other user this changes in AppData is not getting reflected. as AppData folder is user specific.
Any body knows how should I resolve this?
I got one option "Active Setup" will this helps me to resolve this issue?

0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

2 Replies
Community Manager Community Manager
Community Manager

Hi Prashant,

If you put the options configuration file into the "All Users" AppData folder, then maybe the application will pick up the setting from there for all users rather than just the installing user. You might be able to achieve that by modifying the installation package, or installing it for all users (i.e. set the MSI property ALLUSERS=1 at installation time).

(Did my reply solve the question? Click "ACCEPT AS SOLUTION" to help others find answers faster. Liked something? Click "KUDO". Anything expressed here is my own view and not necessarily that of my employer, Flexera.)
0 Kudos

Make sure the component installing the file is associated with the same feature as the exe your running and windows installer should start a self repair when you start the app, provided that the xml file is the key path of the component.

0 Kudos