cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to validate with Installahield 5.5

CChong
By Level 11 Flexeran
Level 11 Flexeran
Hello - I've just installed Windows 2003 Server on a new Dell machine and installed AdminStudio 5.5. When using DevStudio, everything seems to work except the Full Validation Suite. My Build works fine but when I try to perform a Full Validation Suite on it, it just displays the following dialog and stops:

Validation started at 12/29/2003 3:44:52

MSI file to validate:L:\Instpkgs\Adobe\Acrobat40\acrobat40.msi
CUB file used to validate:C:\Program Files\InstallShield\AdminStudio\5.5\DevStudio\Support\darice.cub


I've reinstalled Admin Studio but it didn't help... Any thoughts or help would be appriciated.

Thanks

Tom
System Administrator
University of Southern California
(7) Replies
CChong
By Level 11 Flexeran
Level 11 Flexeran
It could just be taking a long time, although I sometimes get this as well. In these cases, I validate with orca - its free from microsoft in the windows installer sdk. Its also quicker.
CChong
By Level 11 Flexeran
Level 11 Flexeran
If you are also experiencing the problem it may have shipped with a corrupt CUB file or perhaps it's a bug in the 5.5 version of the application. I have a call into our Installshield Consultant about this. After I speak with technical support I will post a followup message with any useful information that they provide.
There a couple of things I know that cause this. One would be. as Murray says, a corrupt cub file but reinstalling AdminsStudio would sort this. So we can rule that out.

The other is validation has been known to intermittently hang when the msi you are validating is already installed on the machine. So uninstall that msi and try to re-validate.
CChong
By Level 11 Flexeran
Level 11 Flexeran
I had the same problem, with almost the same configuration. A Dell server with a Windows 2003 server and InstallShield AdminStudio 5.0.
I found that out by building the package in the Developer, I got an error in the application log:

Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 1008
Date: 1/9/2004
Time: 2:37:58 PM
User: N/A
Computer: H-MS01
Description:
The installation of D:\AdminStudio Training Disk\Making Sense\Example\Product Configuration\Release\DiskImages\Disk1\Making Sense Example.msi is not permitted due to an error in software restriction policy processing. The object cannot be trusted.

I changed the Software Restriction Policies in the Local Security Settings (because our domain is still Windows2000).

The setting:
Enforcement policy-- Apply software restrictions policies to the following users:

From All users to All users exept local administrators.

Now validation is going fine.
TommyR and WillemS:

Thank you for informing InstallShield of this issue, as well as the workaround. I have tried this on our machines here, and have been able to reproduce this issue. It has been reported to our development staff, in the mean time, the workaround that WillemS suggested seems to work just fine.

If you have any other questions, please let us know.
In the MSI SDK Automation Interface help, Installer.OpenPackage and MsiOpenPackageEx have an option

When options is 1, the OpenPackage Method ignores the current computer state when opening the package.

Orca has this set, which is why it can validate packages that are installed locally

DevStudio can not have it set which is why it fails.

looeee
CChong
By Level 11 Flexeran
Level 11 Flexeran
Well, afer running a few tests for InstallShield's tech support we've learned that AdminStudio 5.5 has some issues running under Windows 2003 Server. When I installed Windows XP Pro and then installed AdminStudio 5.5, the Validate function worked fine. They tell me that, in some future release of AdminStudio, this problem will be fixed.

Cheers

Tom