cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Major Upgrade not working

I have 2 applications with different product, upgrade, and package codes. I want version 2.3.X to uninstall 2.2.X. I created an automatic upgrade item and pointed it at the 2.2 msi. It picked up the version and upgrade code and filled them in. The install fails saying "A newer version of this app. is already installed....Please uninstall the newer version first." This is the newer version I'm trying to install. I'm hoping this is something simple. Any help would be appreciated. Thanks
0 Kudos

This thread has been automatically locked due to inactivity.

To continue the discussion, please start a new thread.

1 Reply

Hi Leshon,

This sounds like our new "Prevent Downgrade" custom action we added according to Microsoft Best Practices. This means that you've probably missed something with significant digits, and the way MSI treats them.

Remember:

2.001.00 < 2.01.00

Can you post the ProductVersion values you're using, as well as a logfile of the error occurring?
0 Kudos