cancel
Showing results for 
Search instead for 
Did you mean: 
goody612
Active participant

Error after Installing AES 2019

Jump to solution

After installing AES 2019 and launching Web Components I am getting the below error.  Has anyone experienced this before?Image.png

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator moconn Moderator
Moderator

Re: Error after Installing AES 2019

Jump to solution

Hello @goody612 -

This help applies both to AdminStudio Enterprise Server (AES) and Workflow Manager.

This error comes up because the default ApplicationPoolIdentity account that the AES' application pool in IIS does not have database access to your Application Catalog database.

The primary method is to change the Application Pool Identity for the AdminStudioWebComponents2019 in IIS to the same account you specified as the service account for AES.

Open IIS on the server with AES installed, then...

  1. Click on the Application Pools tree node on the left
  2. Highlight AdminStudioWebComponents2019 in the list of Application Pools
  3. Click Advanced Settings on the Actions pane on the right

IIS - AppPoolId change.pngChange ApplicationPoolIdentity4. Click on the ellipse button (...) next to the Identity field

IIS - AppPoolId change2.png

5. Select Custom Account and click Set...

6. Provide DOMAIN\username and password for the service account you provided when you installed AES

6. Click OK on the Set CredentialsApplication Pool Identity, and Advanced Settings dialog boxes

7. Recycle the AdminStudioWebComponents2019 application pool (found on the Actions pane)

8. Restart the website by going to the Sites > AdminStudioWebComponents2019 tree node in IIS and clicking on Manage Website > Restart option on the Actions pane

9. Close and relaunch the site in your web browser, you should see an username / password log in prompt with the AdminStudio logo

More info from Microsoft on changing Application Identity Pools here: https://docs.microsoft.com/en-us/iis/manage/configuring-security/application-pool-identities

Expert Flexeran on AdminStudio, Workflow Manager, and Software Vulnerability Manager / Research

View solution in original post

Tags (3)
3 Replies
Highlighted
Moderator moconn Moderator
Moderator

Re: Error after Installing AES 2019

Jump to solution

Hello @goody612 -

This help applies both to AdminStudio Enterprise Server (AES) and Workflow Manager.

This error comes up because the default ApplicationPoolIdentity account that the AES' application pool in IIS does not have database access to your Application Catalog database.

The primary method is to change the Application Pool Identity for the AdminStudioWebComponents2019 in IIS to the same account you specified as the service account for AES.

Open IIS on the server with AES installed, then...

  1. Click on the Application Pools tree node on the left
  2. Highlight AdminStudioWebComponents2019 in the list of Application Pools
  3. Click Advanced Settings on the Actions pane on the right

IIS - AppPoolId change.pngChange ApplicationPoolIdentity4. Click on the ellipse button (...) next to the Identity field

IIS - AppPoolId change2.png

5. Select Custom Account and click Set...

6. Provide DOMAIN\username and password for the service account you provided when you installed AES

6. Click OK on the Set CredentialsApplication Pool Identity, and Advanced Settings dialog boxes

7. Recycle the AdminStudioWebComponents2019 application pool (found on the Actions pane)

8. Restart the website by going to the Sites > AdminStudioWebComponents2019 tree node in IIS and clicking on Manage Website > Restart option on the Actions pane

9. Close and relaunch the site in your web browser, you should see an username / password log in prompt with the AdminStudio logo

More info from Microsoft on changing Application Identity Pools here: https://docs.microsoft.com/en-us/iis/manage/configuring-security/application-pool-identities

Expert Flexeran on AdminStudio, Workflow Manager, and Software Vulnerability Manager / Research

View solution in original post

Tags (3)
goody612
Active participant

Re: Error after Installing AES 2019

Jump to solution

Thanks for the information.  That worked to get the login prompt.  Still getting some errors regarding authentication, so I will have to troubleshoot that.

Moderator moconn Moderator
Moderator

Re: Error after Installing AES 2019

Jump to solution

Great, glad that got you past that issue @goody612. You should be able to log in using the "super user" and configure it for Windows Authentication (if desired). More info on logging in with this user here: https://helpnet.flexerasoftware.com/workflowmanager2019/default.htm#helplibrary/WFMFUT_suams.htm

(Note the Workflow Manager applies to AES too when it comes to setting up and configuring the site.)

Expert Flexeran on AdminStudio, Workflow Manager, and Software Vulnerability Manager / Research
0 Kudos