Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error Connecting AdminStudio to SCCM

Attempting to connect to SCCM from AdminStudio, and getting the following error:

Testing connection to 'SCCM'...
WMI exception: Invalid namespace
Connection to basesccm201601 Failed : WMI exception: Invalid namespace
A required process for this task failed

Have verified that the accounts have the correct permissions on the SCCM side as well.

(8) Replies


What is the version of the AdminStudio and the SCCM?

Is the firewall enabled on the machine? If yes, please disable and try to test the connection.

And also try with the IP address of the SCCM machine instead of FQDN.

We are running AdminStudio 2019 and Config Manager 1702.

Windows Firewall is disabled, and we get the same error using the IP address.  


Thanks for the reply.

Please follow below link to generate AdminStudio IDE verbose logs and attach the same to take look :

I hope the SCCM machine is reachable from the machine where AdminStudio is installed.

I would also like to take a look at the screenshot of the SCCM distribution connection configured in the Server options.

See attached after increasing the logging.

See attached for a screenshot of the SCCM connection window from AdminStudio as well.


Thanks for sharing the required logs.

 In the attached screenshot,  I noticed that the credentials entered earlier remained in the distribution system authentication through windows authentication is chosen. can you remove the credentials and try to connect using windows authentication?

By any chance, the credentials used to test the connection using server authentication? If yes, was the connection successful using server authentication?

Currently, I am going through the logs attached, will get back with my findings at the earliest.

We did try Windows Authentication with out any credentials.  We then tried using server authentication with the same error.  I think that is why the credentials are still in's not very friendly when you try to remove the credentials.  You almost have to create a whole new distribution system connection.


I have gone through the attached logs and noticed the below exception.

06:23:11 INFO: AdminStudio.SCCM.Extension.SCCMExtensionBase.IsWmiRunning - WMI service status: Running
06:23:11 ERROR: SCCMPlugin.SCCMPlugin.ConnectSccm - WMI exception: Invalid namespace

Unfortunately, the logs did not give any further indication of what is causing the issue, as the logs contain the same error you observed while testing the connection.

Please verify,  if the site code specified is the valid one for the SCCM being used.

Can you review the steps highlighted in the following Microsoft article to verify namespace and server connectivity?

If the above suggestion also didn't help resolve the issue, then we need to take a look at the environment you are using to investigate the issue further.

If you have a valid support plan, feel free to submit a support case to take it further.