cancel
Showing results for 
Search instead for 
Did you mean: 
jsnyder213
Pilgrim

Custom MSI

Hello.
I am new, so I would like to apologize if this is not in the correct area.
I am trying to build a custom MSI with Repackager 2013. I am using a VM to build the package with remote repackager... I have one setup.exe files for the software to be installed, and 2 .bat files that I have converted to .exe files.
I am using the "installation monitoring" method to create the MSI.

I start the process and everything seems to be working fine. The first custom bat/exe runs and uninstalls a previous version of the software I want to install (I am attmepting to install the newest version). The process then kicks off the setup.exe, and finally ends with the last custom .bat/exe file that copies some files from a network drive.
It eventually ends with my needed irp files, and I use them to create the desired MSI.

However... this is where the problem is. When I run the MSI on a test machine, it seems as if it only caputres the setup.exe process during the build phase. Basically, the .bat/exe files are skipped and it is not included in the completed MSI.

Any sggestions as to what I am missing??
0 Kudos
2 Replies
Highlighted
Mistral
Flexera beginner

Re: Custom MSI

To make it short:
- Try snapshot instead of monitoring
- do not monitor/snapshot the uninstallation ... use a clean machine (without the old version installed)
0 Kudos
jsnyder213
Pilgrim

Re: Custom MSI

Snapshot did not work. Same issue. The setup.exe installs, but the custom .exe files dont execute within the MSI package that is built.
I need the uninstall process. This MSI is being pushed via the network to roughly 1,000 machines. The new version can't be installed with the old version on the machine... so essentially in one package I need to uninstall the old and then install the new.
0 Kudos