Windows Installer Error 1720
Summary
Discussion of causes and solutions for Windows Installer error -1720.Symptoms
When running an installation, the following error occurs:
Error -1720: There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action [2] script error [3], [4]: [5] Line [6], Column [7], [8].
The numbers in brackets [ ] are placeholders for the error-specific information that appears in the error message.
Cause
This is a general error message that indicates that a script-based custom action has failed. This can occur with VBScript, JScript, or InstallScript custom actions.
This error can occur for any of the following reasons:
- An error has occurred within the script that the custom action launches.
- The script has been deleted or moved from the location where the custom action expects to find it.
Resolution
To resolve this error, follow these steps:
- Debug the script contained within the custom action. If it is VBScript or JavaScript, run this code manually outside of InstallShield and make sure it works correctly.* If it is InstallScript, choose the "Debug InstallScript" option in the Build menu of the InstallShield IDE to debug the script and determine where the script fails. If the script fails for any reason, error -1720 occurs. Therefore, debugging the script is invaluable in determining if the script is failing unexpectedly.
For additional information on debugging InstallScript, see the InstallShield Help Library topic Debugging Scripts.
*Note: Any MSI-specific functionality in the script will not work correctly if run outside of InstallShield. In this situation, it is recommended to comment out any MSI-specific code as a test to make sure the other code works correctly. If the MSI-specific functionality is critical and cannot be commented out, insert this code into a new InstallShield project and test it in this situation.
- Make sure the script is in the location where the custom action expects to find it. To verify this, follow these steps:
- Select the Custom Actions view.
- Select the custom action specified in the error message.
- Right-click on the custom action and select Custom Action Wizard.
- Go through the wizard to the Action Type panel and make sure that the Location field contains the correct value.
For example, if the Location is Installed with the product, make sure that the file was installed properly to the target machine and is in the correct location.
For additional information on how each option in the Location field is used and where it stores the script, see the InstallShield Help Library topic "Custom Action Wizard - Action Type Panel."
- If this script-based custom action worked in other projects but is failing in this particular project, make sure that the MSI Type Number is the same by following these steps:
- Select the Custom Actions view.
- Select the custom action specified in the error message.
- In the MSI Type Number property in the right panel, note the value.
- Repeat these steps with the original working project and make sure this value is the same.
- If different, launch the Custom Action Wizard and recreate this custom action in the new project with the identical settings from the original project.
Additional Information
For additional information on custom actions, see the InstallShield Help Library topic Custom Actions.
For a detailed list of all custom action types (MSI Type Numbers), see the MSDN Help Library topic Summary List of All Custom Action Types.