Error: -97,121 - LM_VENDOR_DOWN - "The desired vendor daemon is down"
Summary
Error: -97,121 - LM_VENDOR_DOWN - "The desired vendor daemon is down"
Symptoms
Whilst attempting to checkout a license from a license server, the following error may be observed:
Cause
This error would normally indicate that the client cannot checkout a license from the license server.
The error may be generated due to a problem with the license server, a network issue or that the correct path to the license server has not been passed to the client.
Resolution
1. Check that there are no issues with the license server. Check the debug log for error messages that would indicate a problem and check that the license server has fully started. A log file for a working license server would look something like this:
10:12:12 (lmgrd) pid 7848
10:12:12 (lmgrd) Detecting other license server manager (lmgrd) processes...
10:12:12 (lmgrd) Done rereading
10:12:12 (lmgrd) FLEXnet Licensing (v11.10.0.0 build 95001 i86_n3) started on CHLTFLYNN (IBM PC) (10/13/2011)
10:12:12 (lmgrd) Copyright (c) 1988-2011 Flexera Software, Inc. All Rights Reserved.
10:12:12 (lmgrd) US Patents 5,390,297 and 5,671,412.
10:12:12 (lmgrd) World Wide Web: http://www.flexerasoftware.com
10:12:12 (lmgrd) License file(s): counted.lic
10:12:12 (lmgrd) lmgrd tcp-port 27000
10:12:12 (lmgrd) Starting vendor daemons ...
10:12:12 (lmgrd) Started flexera (pid 5428)
10:12:12 (flexera) FLEXnet Licensing version v11.10.0.0 build 95001 i86_n3
10:12:12 (flexera) Using options file: ".\flexera.opt"
10:12:13 (flexera) Server started on CHLTFLEXERA for: c1
10:12:13 (flexera) c2 c3 c4
10:12:13 (flexera) c5 e2
10:12:13 (flexera) EXTERNAL FILTERS are OFF
10:12:13 (lmgrd) flexera using TCP-port 63051
2. Check that you can ping the server machine from the client machine. If the ping fails then there is most likely an issue with network connection between client and server. Correct ping output would look like this on Windows:
C:\FNP\FNP 11.10\i86_n3>ping chkrispykreme
Pinging chkrispykreme.acresso.com [10.50.0.22] with 32 bytes of data:
Reply from 10.50.0.22: bytes=32 time=7ms TTL=128
Reply from 10.50.0.22: bytes=32 time<1ms TTL=128
Reply from 10.50.0.22: bytes=32 time<1ms TTL=128
Reply from 10.50.0.22: bytes=32 time<1ms TTL=128
Ping statistics for 10.50.0.22:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 7ms, Average = 1ms
3. Check that the license search path is looking at the correct location for the license server. Check the output of lmpath -status and see if the license server machine is listed:
Output from lmpath -status:
C:\FNP\FNP 11.10\i86_n3>lmpath -status
lmpath - Copyright (c) 1989-2011 Flexera Software, Inc. All Rights Reserved.
Known Vendors:
bkmasa: C:\Test files\SIOC-000103518\ReproCaseSIOC-000103518\build\test_r
epro.lic
magnaecs: @localhost
niakwa: 27001@che-tech-sf1
flexera: @localhost
Other Vendors:
C:\flexlm\license.dat
If the path is incorrect, then you can change the values using lmpath -override
If using a port outside of the default flex ports (27000-27009), make sure that the path includes the port number, for example 5555@chltflexera
4. Check the version of the Flexnet Publisher libraries linked into your client application and ensure they are not of a greater version than the vendor daemon.
You can check the version of the client using the FNP utility lmver:
lmver lmflex.exe, should give output, such as:
C:\FNP\FNP 11.10\i86_n3>lmver lmflex.exe
lmver - Copyright (c) 1989-2011 Flexera Software, Inc. All Rights Reserved.
FLEXnet Licensing v11.10.0.0 build 95001 i86_n3 (lmgr.lib), Copyright (c) 1988-2011 Flexera Software, Inc. All Rights Reserved.
Then check the version of the vendor daemon. This is normally indicated in the debug log:
10:06:12 (lmgrd) License file(s): counted.lic
10:06:12 (lmgrd) lmgrd tcp-port 27000
10:06:12 (lmgrd) Starting vendor daemons ...
10:06:12 (lmgrd) Started flexera (pid 1036)
10:06:13 (flexera) FLEXnet Licensing version v11.10.0.0 build 95001 i86_n3
Or you could use lmver - lmver <name of daemon>.exe
Please ensure that the version of the client libraries used are not greater than the version of the vendor daemon.
5. The -97,121 error normally occurs when there is another license server running in the client application environment. If no license servers are running then you would get a -15 error, indicating that the client cannot connect to a license server. The -97 error would indicate that the client has attempted a checkout from a license server for a different vendor and could not locate the correct vendor name for the license that was required.
It would be worth checking the vendor name of the daemon that is running to see if it is the correct vendor daemon for your application.
You can check the debug log to see the vendor daemon name. If the vendor daemon name does not match the client application then this could indicate that you need to start up the correct vendor daemon.
6. For older versions of Flexlm there may be an issue with the lock file. The locking mechanism(s) were removed by an outside program. In pre v8.4 FLEXlm versions there was a lockfile placed into the C:\flexlm directory, along with an lmgrd runtime information file. The files in these directory locations must be R/W capable.