Resolve “ORA-01017: invalid username/password; logon denied” errors in Snow Inventory Oracle Scanner
An Oracle scan on a Linux machine may fail with the following error in SIOS.log:
executeCommandReturnValuesAsString; Output: SQL*Plus: Release 19.0.0.0.0 - Production on Fri Aug 23 16:38:06 2024 Version 19.3.0.0.0 Copyright (c) 1982, 2019, Oracle. All rights reserved. Enter password: ****ERROR: ORA-01017: invalid username/password; logon denied**** Enter user-name:
2024-08-23T16:38:08+07:00; Verbose; *None*; se.snow.oracleaudit.oracle.SqlPlusExecutor; doTheSqlPlusAction; Result from server: SQL*Plus: Release 19.0.0.0.0 - Production on Fri Aug 23 16:38:06 2024 Version 19.3.0.0.0 Copyright (c) 1982,
The Snow Agent configuration file specifies the credentials used for the Oracle instance. This error indicates that the instance username or password configured for the Oracle instance on the machine is incorrect.
For example:
<Oracle enabled="true">
<Include>
<AllInstances>true</AllInstances>
</Include>
<DefaultInstanceCredentials>
<Password>18341B9FE47362BC2D17E4F148EEB9F6B54A13</Password>
<UserName>Oracle_Scanner</UserName>
</DefaultInstanceCredentials>
</Oracle>
In this example, the password value is quite short.
The recommended solution is to check with the Oracle Database Administrator whether the configured credentials are correct.
If the credentials are incorrect:
- Update them with the correct username and password.
- Follow the process to encrypt the password.
- Use the generated encrypted password in the Snow Agent configuration file for the machine.
Alternatively, if there is no requirement to use a specific username or account after checking with the Oracle Database Administrator, you may be able to remove the DefaultInstanceCredentials, UserName, and Password values from the Snow Agent configuration file.
This is called Automatic Inventory.
For example:
<Oracle enabled="true">
<Include>
<AllInstances>true</AllInstances>
</Include>
</Oracle>